aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-Generate-usable-qmake_extras.gypi.patch71
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 72 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0004-Generate-usable-qmake_extras.gypi.patch b/recipes-qt/qt5/qtwebengine/0004-Generate-usable-qmake_extras.gypi.patch
new file mode 100644
index 00000000..89f56e05
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0004-Generate-usable-qmake_extras.gypi.patch
@@ -0,0 +1,71 @@
+From 9d2fafdd9a15adf51d8383bdd545d73e76ad0428 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@theqtcompany.com>
+Date: Mon, 11 May 2015 13:47:06 +0300
+Subject: [PATCH] Generate usable qmake_extras.gypi
+
+Running qmake recursively does not take .depends into account, so
+the SUBDIRS need to be in correct order so that qmake_extras.gypi
+is used for the ninja files. Do no try to write compiler tools as
+it will break the build.
+
+Task-number: QTBUG-45706
+Upstream-Status: Pending
+---
+ src/core/core.pro | 7 ++++---
+ src/core/gyp_configure_host.pro | 3 ---
+ src/core/gyp_configure_target.pro | 3 ---
+ 3 files changed, 4 insertions(+), 9 deletions(-)
+
+diff --git a/src/core/core.pro b/src/core/core.pro
+index cf00f39..747b711 100644
+--- a/src/core/core.pro
++++ b/src/core/core.pro
+@@ -12,9 +12,7 @@ gyp_run.depends = core_gyp_generator
+ core_module.file = core_module.pro
+ core_module.depends = gyp_run
+
+-SUBDIRS += core_gyp_generator \
+- gyp_run \
+- core_module
++SUBDIRS += core_gyp_generator
+
+ !win32 {
+ # gyp_configure_host.pro and gyp_configure_target.pro are phony pro files that
+@@ -28,3 +26,6 @@ SUBDIRS += core_gyp_generator \
+ gyp_run.depends += gyp_configure_host gyp_configure_target
+ SUBDIRS += gyp_configure_host gyp_configure_target
+ }
++
++SUBDIRS += gyp_run \
++ core_module
+diff --git a/src/core/gyp_configure_host.pro b/src/core/gyp_configure_host.pro
+index 3eb6738..d6820c4 100644
+--- a/src/core/gyp_configure_host.pro
++++ b/src/core/gyp_configure_host.pro
+@@ -6,9 +6,6 @@ option(host_build)
+
+ GYPI_CONTENTS = "{" \
+ " 'make_global_settings': [" \
+- " ['CC.host', '$$which($$QMAKE_CC)']," \
+- " ['CXX.host', '$$which($$QMAKE_CXX)']," \
+- " ['LD.host', '$$which($$QMAKE_LINK)'],"
+
+ GYPI_FILE = $$absolute_path('qmake_extras.gypi')
+ !build_pass {
+diff --git a/src/core/gyp_configure_target.pro b/src/core/gyp_configure_target.pro
+index 4d52044..f02bfa0 100644
+--- a/src/core/gyp_configure_target.pro
++++ b/src/core/gyp_configure_target.pro
+@@ -3,9 +3,6 @@ TEMPLATE = aux
+
+ TOOLCHAIN_INCLUDES = $${QMAKE_INCDIR_EGL} $${INCLUDEPATH} $${QMAKE_INCDIR}
+
+-GYPI_CONTENTS += " ['CC', '$$which($$QMAKE_CC)']," \
+- " ['CXX', '$$which($$QMAKE_CXX)']," \
+- " ['LD', '$$which($$QMAKE_LINK)'],"
+ GYPI_CONTENTS += " ]," \
+ " 'target_defaults': {" \
+ " 'target_conditions': [" \
+--
+1.9.1
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 27873b77..6685e53a 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -79,6 +79,7 @@ SRC_URI += " \
file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \
file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \
file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \
+ file://0004-Generate-usable-qmake_extras.gypi.patch \
file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \
"
SRCREV_qtwebengine = "c6573119006014ff7bc0efb2da16ea35d302a1ec"