aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d-runtime_git.bb6
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb20
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtgamepad_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtknx_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb9
-rw-r--r--recipes-qt/qt5/qtpurchasing_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
41 files changed, 48 insertions, 63 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 82b6da92..be7b2eb6 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -193,4 +193,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "b527725766df850fcad6b9078fea5e8da8085560"
+SRCREV = "534df5a33bd6a3d0d00194212cf868a9ef57bd53"
diff --git a/recipes-qt/qt5/qt3d-runtime_git.bb b/recipes-qt/qt5/qt3d-runtime_git.bb
index 8df143ae..fb018e58 100644
--- a/recipes-qt/qt5/qt3d-runtime_git.bb
+++ b/recipes-qt/qt5/qt3d-runtime_git.bb
@@ -9,8 +9,8 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qt3d"
-QT_MODULE_BRANCH = "2.2"
+QT_MODULE_BRANCH = "2.3"
QT_GIT_PROJECT = "qt3dstudio"
-PV = "2.2+git${SRCPV}"
+PV = "2.3+git${SRCPV}"
-SRCREV = "8cdb99c910f2f57972b652c3fb8d520ba615f110"
+SRCREV = "5e0bfe934b9930b7e41d457b4f88fce91342a0ea"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index bcc63058..c09abf5f 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "7da5c4c35a657ea43663b4ed0d65e896b8db5c69"
+SRCREV = "29c20fda753f25bd142e18d511d28da68c6361c2"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 1866f3e5..0893a120 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -3,7 +3,7 @@
QT_MODULE ?= "${BPN}"
QT_MODULE_BRANCH ?= "5.12"
-QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH}"
+QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH};nobranch=1"
# each module needs to define valid SRCREV
SRC_URI = " \
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 91ed4807..eb9b5514 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -141,4 +141,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "b527725766df850fcad6b9078fea5e8da8085560"
+SRCREV = "534df5a33bd6a3d0d00194212cf868a9ef57bd53"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 99adbb6b..5df0043e 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -275,22 +275,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-TARGET_MKSPEC ?= "linux-g++"
-
-# use clean mkspecs on target
-pkg_postinst_${PN}-tools () {
-sed -i \
- -e 's:HostSpec =.*:HostSpec = ${TARGET_MKSPEC}:g' \
- -e 's:TargetSpec =.*:TargetSpec = ${TARGET_MKSPEC}:g' \
- $D${bindir}/qt.conf
-}
-
-pkg_postinst_${PN}-mkspecs () {
-sed -i 's: cross_compile : :g' $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qconfig.pri
-sed -i \
- -e 's: cross_compile : :g' \
- -e 's:HOST_QT_TOOLS =.*::g' \
- $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
-}
-
-SRCREV = "b527725766df850fcad6b9078fea5e8da8085560"
+SRCREV = "534df5a33bd6a3d0d00194212cf868a9ef57bd53"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index de5655d3..76b6dc54 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "e722ccfe62f2745b2da3b8b1202f8d224c3e5a5f"
+SRCREV = "912b9b3b1318aac4cef681315ae1588105eaf410"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index bde9f40e..84173957 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "dcc4fd4fe0aff770204272d04749184df133bbb2"
+SRCREV = "9755f474a039756b98ce9c2bf0a69809b1396004"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 414ce334..7c3a209f 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -21,4 +21,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "9a77336d4984875d95f48b20a521c34f742e0fa7"
+SRCREV = "6a8a8f328d1782319b4dc0e4b3497e6613e0f864"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index e9252f33..4465660e 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "4672b6d2c725a74d482a76d6624671ae3a2ba2a1"
+SRCREV = "edabd45add4b440b40e05f742a5a3a8b124cf72e"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 41481b4c..82ae4975 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -24,6 +24,6 @@ do_install_append_class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "95c938cd67a1f9ccaf5a3a5fd40993f619786ca9"
+SRCREV = "5ead393eba0fc9d7c05790887c53c3728b023195"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb
index 2a142ece..cc19abb2 100644
--- a/recipes-qt/qt5/qtgamepad_git.bb
+++ b/recipes-qt/qt5/qtgamepad_git.bb
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "48eeb8adf8ccf9eef284b7c6406708bf724f3652"
+SRCREV = "cf48d4694edd6a16cd3bf56922ab20d8bd6b7fe7"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index 8ba59471..d7481ff8 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -18,4 +18,4 @@ RDEPENDS_${PN}-dev = ""
# http://errors.yoctoproject.org/Errors/Build/44912/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "9c70295220c6dc7f8b4ba8d8406084129e317a6f"
+SRCREV = "8cf6af2c897a822e040015b169fbf13f3db63ebf"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 75442663..3f57d702 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "5e433bcefaebb8dac20edb96170349f9a0adde5d"
+SRCREV = "17ac003f6072e62ba9de7e75f3de8b8509dcd2c3"
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index ead1b19b..84102fa4 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "0dfc76b080df56ef1638bd6a9deb7325692bc242"
+SRCREV = "ae6c0fe18fff0bedced9800b11940f396b66596d"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index f4fedf14..442ae146 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -31,7 +31,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "cbcff2b083df51fb96f38cd64446f4e5afb3b2d1"
+SRCREV_qtlocation = "a8ecb45143823912baef2426f8e352159fcb0f9a"
SRCREV_qtlocation-mapboxgl = "4b85252fbe811a786c6ee9eabedb7639b031dc53"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index d83ce919..46b22a01 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "6281dd7e375f94a5e7f78055c0bebba93a2b0e02"
+SRCREV = "cf41d84738f0ed0c779f75db94d413ad938fb901"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 30f9c9e4..4e657110 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "64981aee3bbbe2c4f5503b458636a84df822b0ec"
+SRCREV = "c7e735198c6cc01201f90b64c8a6d35fc40584fc"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index 849feeb9..d0f80291 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "5c9251aebb487a6c328f2d706002ca2039aff5ac"
+SRCREV = "0da27832617a17788da4fdd6838f8aa6d8c70f65"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index a86abbca..50f9ac88 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -1,18 +1,21 @@
require qt5.inc
require qt5-git.inc
-LICENSE = "GFDL-1.3 & ( GPL-2.0+ | LGPL-3.0 ) | The-Qt-Company-Commercial"
+LICENSE = "( GFDL-1.3 & ( GPL-2.0+ | LGPL-3.0 ) | The-Qt-Company-Commercial ) & MPL-2.0 & CC0-1.0"
LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=f70ee9a6c44ae8917586fea34dff0ab5 \
file://LICENSE.GPLv2;md5=05832301944453ec79e40ba3c3cfceec \
file://LICENSE.LGPLv3;md5=c4fe8c6de4eef597feec6e90ed62e962 \
"
+PACKAGECONFIG ?= "qtdeclarative"
+PACKAGECONFIG[qtdeclarative] = ",,qtdeclarative"
+
# src/3rdparty/open62541.pri adds -Wno-format, causing following error
# because -Wformat-security cannot be used together with -Wno-format
# cc1: error: -Wformat-security ignored without -Wformat [-Werror=format-security]
SECURITY_STRINGFORMAT = ""
-DEPENDS += "qtbase qtdeclarative"
+DEPENDS += "qtbase"
-SRCREV = "56d2b5df55c9a6ea7d21f3412193903f2504249e"
+SRCREV = "9d61cbee4131a8b6774ba242fe6e3f2b2f5e853c"
diff --git a/recipes-qt/qt5/qtpurchasing_git.bb b/recipes-qt/qt5/qtpurchasing_git.bb
index 0750fe68..4f19fdd2 100644
--- a/recipes-qt/qt5/qtpurchasing_git.bb
+++ b/recipes-qt/qt5/qtpurchasing_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "aa924c0575c54c93a5b95ace4083c34f309a16d0"
+SRCREV = "45f2b4a63489c614e0060b511e00245c599fbb70"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index d41c4b3a..c163ef42 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "f7ba074ca19f5f3d2d7580616144c65f35b48072"
+SRCREV = "db38242b288fe3ca8f7461cf344b757a9ca0947d"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index d7d9170f..d9a027d6 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "3a5ac4885b4818489120e9b46c208737ad202fb6"
+SRCREV = "718afd7c3a78a35e3f4073dc6447e6bf3fda82d4"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index d4fd74cc..b7b77a4e 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -24,6 +24,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "db1e447c46062946e57d7de9c0e0ea5fddc997f6"
+SRCREV = "043f7582bb2f611120a7693fbe75fa866d046fff"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index cebd863d..230f7350 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -36,4 +36,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "2f6a1056f10dbe634c58725ad2893c6cee58bf1c"
+SRCREV = "038f6305610a80f39d3416b95b5df96fab0c801d"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index e71d2828..16599978 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "755c5a753d77f4c8f53788c870240e60673417a0"
+SRCREV = "daad96b2b9a4b503aebbea4f77887973dd8ff8ee"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.12
# 5.12.meta-qt5.2
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index 41c31283..4655b2a7 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "b1cb2782b369413add8aeb4c4e6c1453bbf5e367"
+SRCREV = "6b7f7f5ceb7a230307c004021a2f16f3dabdf759"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 4b912be4..facff866 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "64199169df6bd5b1e31d934c0a64c13d57d0f5c4"
+SRCREV = "9102ab868037042cab292dbfaa08f8dfff8ef5a8"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 1dad6ad1..4b76a4f7 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "6fad8e67d879b1979c48ee615a972571a6426718"
+SRCREV = "208e76d05719fe2262ff6e162786894ddb3d0fb6"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index c167f0a7..164de449 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "a4c2e4de3c8c248a340bef815105371f365a456a"
+SRCREV = "fd12ae24b4542cf2f0df1a34187c4b8c0a408e01"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index d2b905b6..25b87aa9 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -32,7 +32,7 @@ EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
"
-SRCREV = "1f8d498752fed0b2b92d6a619aa11524dd771998"
+SRCREV = "fe5b4f8e7ac984cc4c9698e7d6def9be46b0df7a"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 88948a56..f06ca308 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -98,4 +98,4 @@ FILES_${PN}-qthelp = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_help_*.qm \
"
-SRCREV = "8cd09ac290c75eeeb91c015e7d7791b15c0cac5e"
+SRCREV = "0987e6cb7f415be17d1240c8cd71719f94a98f76"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 55f39205..f1317c90 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "c7f9640cb883c05e1ba51dac69078782b7eff855"
+SRCREV = "152f6935f050e83363f1b4f40c40af7f64ca5df9"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 58ffbe78..36147c31 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[wayland-libhybris-egl-server-buffer] = "-feature-wayland-libhybris
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "bcdc00bcdc67ee478369c04c994c1f576e51cfab"
+SRCREV = "e70a8070ea1e7903221fb980ddf3c23f3e9b0836"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index cc3c867a..f2a15500 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "5bcd09ac1b670658c77b7712873c75893e4a41a4"
+SRCREV = "c3574f4ec36f3cab71fcb680e889afc8a16c6242"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index b65ceea5..d612552a 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -174,7 +174,7 @@ SRC_URI_append_libc-musl = "\
file://chromium/0018-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "c7b8d6d87809253241913c595902a11ea506b2b7"
+SRCREV_qtwebengine = "7ba379ecfa575f871a52dc94c9f29e2bfdfc9865"
SRCREV_chromium = "4c7ecce30045daf172dceaeeb86351f60cc91990"
SRCREV = "${SRCREV_qtwebengine}"
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
index 01538d0d..51cdfdb5 100644
--- a/recipes-qt/qt5/qtwebglplugin_git.bb
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -18,4 +18,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "9007ba49d14ef56e56a2114685ddd5b23e25f5c8"
+SRCREV = "10a64558ce927e2df0f2dfe7ff3d786d4737c06e"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index 59f5cd85..53dd6b15 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "0f1373617f2d1c562fd448fee207f7d99a0191bc"
+SRCREV = "c8704b3dbcfecd774244300943b1c63e2bf9841f"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index 60733298..bec8c326 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "3ae7d8eac3a46b5a70d71c556703ce2f21c169dc"
+SRCREV = "05657f1c4744123ff63306a56cb699f2cfbc9f92"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index aca99236..9b999b7b 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "b5c05ebc46fde8e98e388cd5bf86795b040da505"
+SRCREV = "719d3c88670203fca21a3433b553bc2c1434a2ac"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index 103648eb..d1ea2d5c 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -25,7 +25,7 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "f969bdea083012282806ae83a38ace53ef1ba600"
+SRCREV = "6feae569229fa391454b76450138ce83cf326046"
BBCLASSEXTEND =+ "native nativesdk"