aboutsummaryrefslogtreecommitdiffstats
path: root/coin/module_config.yaml
diff options
context:
space:
mode:
Diffstat (limited to 'coin/module_config.yaml')
-rw-r--r--coin/module_config.yaml74
1 files changed, 46 insertions, 28 deletions
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
index be2cc694..8ae9c795 100644
--- a/coin/module_config.yaml
+++ b/coin/module_config.yaml
@@ -15,9 +15,9 @@ machine_type:
# Target build matrix:
#
-# [target1] [target2] [target3] [target4]
-# [machine] qemuarm64 qemux86 qemuarm qemux86-64
-# [yocto] gatesgarth dunfell hardknott honister
+# [target1] [target2] [target3] [target4]
+# [machine] qemuarm64 qemux86 qemuarm qemux86-64
+# [yocto] kirkstone dunfell langdale master
#
target1: &target1
@@ -27,8 +27,11 @@ target1: &target1
variableName: MACHINE
variableValue: qemuarm64
- type: EnvironmentVariable
- variableName: YOCTO_BRANCH
- variableValue: gatesgarth
+ variableName: MANIFEST
+ variableValue: kirkstone.xml
+ - type: EnvironmentVariable
+ variableName: TEST_CONFIGS
+ variableValue: ci configs
enable_if:
condition: property
property: target.arch
@@ -40,8 +43,11 @@ target2: &target2
variableName: MACHINE
variableValue: qemux86
- type: EnvironmentVariable
- variableName: YOCTO_BRANCH
- variableValue: dunfell
+ variableName: MANIFEST
+ variableValue: dunfell.xml
+ - type: EnvironmentVariable
+ variableName: TEST_CONFIGS
+ variableValue: ci configs
enable_if:
condition: property
property: target.arch
@@ -53,8 +59,11 @@ target3: &target3
variableName: MACHINE
variableValue: qemuarm
- type: EnvironmentVariable
- variableName: YOCTO_BRANCH
- variableValue: hardknott
+ variableName: MANIFEST
+ variableValue: langdale.xml
+ - type: EnvironmentVariable
+ variableName: TEST_CONFIGS
+ variableValue: ci configs
enable_if:
condition: property
property: target.arch
@@ -66,8 +75,11 @@ target4: &target4
variableName: MACHINE
variableValue: qemux86-64
- type: EnvironmentVariable
- variableName: YOCTO_BRANCH
- variableValue: honister
+ variableName: MANIFEST
+ variableValue: master.xml
+ - type: EnvironmentVariable
+ variableName: TEST_CONFIGS
+ variableValue: ci configs
enable_if:
condition: property
property: target.arch
@@ -99,31 +111,37 @@ instructions:
sudo hostname $(hostname -s)-$(date +%s%N)
sudo mkdir -p /mnt/yocto-cache
- sudo mount yocto-cache.intra.qt.io:/srv/yocto-cache /mnt/yocto-cache
+ sudo mount yocto-cache.ci.qt.io:/srv/yocto-cache /mnt/yocto-cache
+
+ curl https://storage.googleapis.com/git-repo-downloads/repo > repo
+ chmod +x repo
- git clone git://git.yoctoproject.org/poky --reference /mnt/yocto-cache/mirror/poky.git
- (cd poky; git checkout ${YOCTO_BRANCH})
- git clone git://git.openembedded.org/meta-openembedded --reference /mnt/yocto-cache/mirror/meta-openembedded.git
- (cd meta-openembedded; git checkout ${YOCTO_BRANCH})
- git clone git://git.openembedded.org/meta-python2 --reference /mnt/yocto-cache/mirror/meta-python2.git
- (cd meta-python2; git checkout ${YOCTO_BRANCH})
+ ./repo init \
+ --repo-url https://github.com/theqtcompany/git-repo \
+ -u git://code.qt.io/yocto/boot2qt-manifest \
+ -b ci \
+ -m ${MANIFEST} \
+ --reference /mnt/mirror
+ ./repo sync
source ./poky/oe-init-build-env
- export BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE SSTATE_DIR DL_DIR"
- export DL_DIR=/mnt/yocto-cache/downloads
- export BB_GENERATE_MIRROR_TARBALLS=1
- export SSTATE_DIR=/mnt/yocto-cache/sstate-caches/$(sed -n -e "s/DISTRO_CODENAME.*\"\(.*\)\"/\1/p" ../poky/meta-*/conf/distro/poky.conf)-meta-qt5
+
+ # meta-python2 layer master branch compatible with kirkstone only
+ echo "LAYERSERIES_COMPAT_meta-python2:append = \" langdale mickledore nanbield scarthgap\"" >> ../meta-python2/conf/layer.conf
+
bitbake-layers add-layer ../meta-openembedded/meta-oe
bitbake-layers add-layer ../meta-python2
bitbake-layers add-layer ${SOURCE_DIR}
- echo "require ${SOURCE_DIR}/coin/test-configs.inc" >> conf/local.conf
- # EXCLUDE_FROM_WORLD
+ for conf in ${TEST_CONFIGS}; do
+ echo "require ${SOURCE_DIR}/coin/test-${conf}.inc" >> conf/local.conf
+ done
+
+ # EXCLUDE FROM WORLD
rm -fv ${SOURCE_DIR}/recipes-qt/examples/qt5-opengles2-test_git.bb
- rm -rv ${SOURCE_DIR}/recipes-python/pyqt5/python3-pyqt5_*.bb
- rm -rv ${SOURCE_DIR}/recipes-python/pyqtchart/python3-pyqtchart_*.bb
- # build all recipes found in the layer
- bitbake $(find ${SOURCE_DIR} -name *.bb | xargs -n1 basename | sed -e 's/\([^._]*\).*/\1/')
+
+ # build only recipes found under recipes-qt
+ bitbake $(find ${SOURCE_DIR}/recipes-qt -name *.bb | xargs -n1 basename | sed -e 's/\([^._]*\).*/\1/')
filename: "{{.BuildDir}}/start-build"
fileMode: 420
- type: ExecuteCommand