aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-python/pyqt5/python-pyqt5_5.13.2.bb')
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.13.2.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
index b8b1d086..e051b156 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
@@ -1,6 +1,11 @@
require python-pyqt5.inc
-inherit pythonnative python-dir
+inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative python-dir", "", d)}
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}
DEPENDS += "sip sip-native python"