aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-python/pyqt5/python3-pyqt5-sip_12.13.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-python/pyqt5/python3-pyqt5-sip_12.13.0.bb')
-rw-r--r--recipes-python/pyqt5/python3-pyqt5-sip_12.13.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-python/pyqt5/python3-pyqt5-sip_12.13.0.bb b/recipes-python/pyqt5/python3-pyqt5-sip_12.13.0.bb
new file mode 100644
index 00000000..1b0da4ba
--- /dev/null
+++ b/recipes-python/pyqt5/python3-pyqt5-sip_12.13.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "The sip module support for PyQt5"
+HOMEPAGE = "https://pypi.org/project/PyQt5-sip/"
+LICENSE = "SIP | GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9cd437778ebd1c056a76b4ded73b3a6d"
+
+SRC_URI[sha256sum] = "7f321daf84b9c9dbca61b80e1ef37bdaffc0e93312edae2cd7da25b953971d91"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "PyQt5_sip"
+
+# Fix build with gcc-14
+# http://errors.yoctoproject.org/Errors/Details/761512/
+# siplib.c:3900:20: error: assignment to 'sipSimpleWrapper *' {aka 'struct _sipSimpleWrapper *'} from incompatible pointer type 'PyObject *' {aka 'struct _object *'} [-Wincompatible-pointer-types]
+CFLAGS += "-Wno-error=incompatible-pointer-types"