aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/maliit/maliit-framework-qt5_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/maliit/maliit-framework-qt5_git.bb')
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index 1f0dc8d6..72e6be5f 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -75,12 +75,9 @@ do_install_append() {
install -m 644 ${WORKDIR}/maliit-server.desktop ${D}${datadir}/applications
}
-pkg_postinst_${PN} () {
+pkg_postinst_ontarget_${PN} () {
#!/bin/sh
# should run online
-if [ "x$D" != "x" ]; then
- exit 1
-fi
echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile
ln -s /usr/share/applications/maliit-server.desktop /etc/xdg/autostart/maliit-server.desktop
}
@@ -89,12 +86,11 @@ pkg_postrm_${PN} () {
#!/bin/sh
# should run online
if [ "x$D" = "x" ]; then
- exit 1
-fi
-if [ -e "/etc/xprofile" ]; then
- sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile
+ if [ -e "/etc/xprofile" ]; then
+ sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile
+ fi
+ rm -f /etc/xdg/autostart/maliit-server.desktop
fi
-rm -f /etc/xdg/autostart/maliit-server.desktop
}
S = "${WORKDIR}/git"