aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 2ebd33f0..93b4b9f1 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -15,6 +15,8 @@ LIC_FILES_CHKSUM = " \
QT_MODULE = "qtbase"
+inherit pkgconfig
+
require nativesdk-qt5.inc
require qt5-git.inc
@@ -23,7 +25,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.9
+# 5.12.meta-qt5-shared.12
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -42,14 +44,15 @@ SRC_URI += "\
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-Fix-Wdeprecated-copy-warnings.patch \
+ file://0018-qfloat16-Include-limits-header.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.9
+# 5.12.meta-qt5-native.12
SRC_URI += " \
- file://0018-Always-build-uic-and-qvkgen.patch \
- file://0019-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0019-Always-build-uic-and-qvkgen.patch \
+ file://0020-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
@@ -194,4 +197,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "8edba37d549f9cf9320677006d0786fc230bb315"
+SRCREV = "01272c0948be9f1c6b8a3eff328b931f47d38649"