aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 3c4f31cc..020ada23 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -66,6 +66,7 @@ FILES_${PN}-dev += " \
FILES_${PN} += " \
${SDKPATHNATIVE}/environment-setup.d \
+ ${OE_QMAKE_PATH_PLUGINS} \
"
# qttools binaries are placed in a subdir of bin in order to avoid
@@ -74,6 +75,10 @@ FILES_${PN} += " \
# disable package auto-renaming for the tools-package.
DEBIAN_NOAUTONAME_${PN} = "1"
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[gui] = "-gui -qpa minimal,-no-gui,"
+PACKAGECONFIG[imageformats] = "-qt-libpng -qt-libjpeg -gif -ico, -no-libpng -no-libjpeg -no-ico -no-gif,"
+
QT_CONFIG_FLAGS += " \
-shared \
-silent \
@@ -102,12 +107,8 @@ do_configure() {
-no-gcc-sysroot \
-system-zlib \
-dbus-runtime \
- -no-libjpeg \
- -no-libpng \
- -no-gif \
-no-accessibility \
-no-cups \
- -no-gui \
-no-sql-mysql \
-no-sql-sqlite \
-no-opengl \
@@ -149,7 +150,6 @@ do_install() {
# remove things unused in nativesdk, we need the headers and libs
rm -rf ${D}${datadir} \
- ${D}/${OE_QMAKE_PATH_PLUGINS} \
${D}${libdir}/cmake \
${D}${libdir}/pkgconfig