aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtpdf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtpdf_git.bb')
-rw-r--r--recipes-qt/qt5/qtpdf_git.bb28
1 files changed, 15 insertions, 13 deletions
diff --git a/recipes-qt/qt5/qtpdf_git.bb b/recipes-qt/qt5/qtpdf_git.bb
index dd77bc66..d49a5305 100644
--- a/recipes-qt/qt5/qtpdf_git.bb
+++ b/recipes-qt/qt5/qtpdf_git.bb
@@ -71,6 +71,7 @@ COMPATIBLE_MACHINE:armv6 = "(.*)"
COMPATIBLE_MACHINE:armv7a = "(.*)"
COMPATIBLE_MACHINE:armv7ve = "(.*)"
COMPATIBLE_MACHINE:aarch64 = "(.*)"
+COMPATIBLE_MACHINE:riscv64 = "(.*)"
inherit qmake5
inherit gettext
@@ -90,6 +91,7 @@ require qt5-git.inc
export GN_PKG_CONFIG_HOST = "${STAGING_BINDIR_NATIVE}/pkg-config-native"
export GN_HOST_TOOLCHAIN_EXTRA_CPPFLAGS = "-I${STAGING_DIR_NATIVE}/usr/include"
+export GN_HOST_TOOLCHAIN_EXTRA_LDFLAGS = "-L${STAGING_LIBDIR_NATIVE}"
export NINJAFLAGS="${PARALLEL_MAKE}"
do_configure() {
@@ -128,8 +130,8 @@ RDEPENDS:${PN}-examples += " \
QT_MODULE_BRANCH_CHROMIUM = "87-based"
-QT_MODULE_BRANCH = "5.15.10"
-PV = "5.15.10+git${SRCPV}"
+QT_MODULE_BRANCH = "5.15"
+PV = "5.15.13+git${SRCPV}"
# Uses the same repository and couple patches as qtwebengine, but qtwebengine
# still depends on python2
@@ -137,14 +139,14 @@ QT_MODULE = "qtwebengine"
FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtwebengine:"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15-glibc
-# 5.15-glibc.meta-qt5.15
+# 5.15-glibc.meta-qt5.17
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
file://0001-Force-host-toolchain-configuration.patch \
- file://0002-qmake.conf-lower-MODULE_VERSION-to-5.15.4.patch \
+ file://0002-qmake.conf-lower-MODULE_VERSION-to-5.15.X.patch \
"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15
-# 5.15.meta-qt5.15
+# 5.15.meta-qt5.17
SRC_URI:append:libc-musl = "\
file://0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
file://0004-musl-link-against-libexecinfo.patch \
@@ -152,7 +154,7 @@ SRC_URI:append:libc-musl = "\
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based-glibc
-# 87-based-glibc.meta-qt5.9
+# 87-based-glibc.meta-qt5.11
SRC_URI += " \
file://chromium/0001-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
file://chromium/0002-chromium-fix-build-with-clang.patch;patchdir=src/3rdparty \
@@ -164,12 +166,13 @@ SRC_URI += " \
file://chromium/0008-chromium-Move-CharAllocator-definition-to-a-header-f.patch;patchdir=src/3rdparty \
file://chromium/0009-chromium-Link-v8-with-libatomic-on-x86.patch;patchdir=src/3rdparty \
file://chromium/0010-chromium-icu-use-system-library-only-targets.patch;patchdir=src/3rdparty \
- file://chromium/0011-chromium-Remove-TRUE-to-prep-landing-of-icu68.patch;patchdir=src/3rdparty \
- file://chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch;patchdir=src/3rdparty \
+ file://chromium/0011-chromium-skia-Fix-build-with-gcc-12.patch;patchdir=src/3rdparty \
+ file://chromium/0012-Remove-unsetting-_FILE_OFFSET_BITS.patch;patchdir=src/3rdparty \
+ file://chromium/0013-Fix-build-with-gcc-13.patch;patchdir=src/3rdparty \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based
-# 87-based.meta-qt5.9
+# 87-based.meta-qt5.11
SRC_URI:append:libc-musl = "\
file://chromium/0013-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
file://chromium/0014-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
@@ -184,9 +187,8 @@ SRC_URI:append:libc-musl = "\
file://chromium/0023-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "c7e716ef1ffd63a8ab1f4dbf879230849eb3b505"
-# this is 3 commits ahead of what submodule in 5.15.10 uses (caba2fcb0fe8a8d213c4c79d26da3bb88eee61c7), but contains useful fix:
-SRCREV_chromium = "ecc2bb74f1f7140fc52650042299be18e826b27b"
+SRCREV_qtwebengine = "d15a42baae7141952e91665bed22a7c7cfb54b95"
+SRCREV_chromium = "fb66d7ca9641724670c96e999ad5b0fd6eb78d46"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
@@ -203,7 +205,7 @@ INSANE_SKIP:${PN} += "textrel"
# First patch skips "python2" dependency checks for the pdf module
# Second patch repairs a failing build of the `gn` buildtool due to missing (host) libstdc++
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15-qtpdf
-# 5.15-qtpdf.meta-qt5.2
+# 5.15-qtpdf.meta-qt5.5
SRC_URI += " \
file://0001-configure.json-remove-python2-dependency.patch \
file://0002-gn.pro-do-not-try-to-statically-link-stdc.patch \