aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtpdf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtpdf_git.bb')
-rw-r--r--recipes-qt/qt5/qtpdf_git.bb52
1 files changed, 43 insertions, 9 deletions
diff --git a/recipes-qt/qt5/qtpdf_git.bb b/recipes-qt/qt5/qtpdf_git.bb
index 0e9e4850..d7a19cb7 100644
--- a/recipes-qt/qt5/qtpdf_git.bb
+++ b/recipes-qt/qt5/qtpdf_git.bb
@@ -128,8 +128,8 @@ RDEPENDS:${PN}-examples += " \
QT_MODULE_BRANCH_CHROMIUM = "87-based"
-QT_MODULE_BRANCH = "5.15"
-PV = "5.15.8+git${SRCPV}"
+QT_MODULE_BRANCH = "5.15.10"
+PV = "5.15.10+git${SRCPV}"
# Uses the same repository and couple patches as qtwebengine, but qtwebengine
# still depends on python2
@@ -137,25 +137,56 @@ QT_MODULE = "qtwebengine"
FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtwebengine:"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15-glibc
-# 5.15-glibc.meta-qt5.13
+# 5.15-glibc.meta-qt5.14
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
file://0001-Force-host-toolchain-configuration.patch \
- file://0002-qmake.conf-lower-MODULE_VERSION-to-5.15.2.patch \
- file://0002-Remove-the-GN-settings-done-for-clang-that-conflict-.patch \
+ file://0002-qmake.conf-lower-MODULE_VERSION-to-5.15.4.patch \
"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15
-# 5.15.meta-qt5.13
+# 5.15.meta-qt5.14
SRC_URI:append:libc-musl = "\
file://0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
file://0004-musl-link-against-libexecinfo.patch \
file://0005-mkspecs-Allow-builds-with-libc-glibc.patch \
"
-SRC_URI:append:runtime-llvm = " file://native-clang.patch "
+# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based-glibc
+# 87-based-glibc.meta-qt5.9
+SRC_URI += " \
+ file://chromium/0001-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
+ file://chromium/0002-chromium-fix-build-with-clang.patch;patchdir=src/3rdparty \
+ file://chromium/0003-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \
+ file://chromium/0004-chromium-Do-not-try-to-set-the-guessed-values-for.patch;patchdir=src/3rdparty \
+ file://chromium/0005-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \
+ file://chromium/0006-chromium-Fix-build-on-32bit-arches-with-64bit-time_t.patch;patchdir=src/3rdparty \
+ file://chromium/0007-chromium-Include-cstddef-for-size_t-definition.patch;patchdir=src/3rdparty \
+ file://chromium/0008-chromium-Move-CharAllocator-definition-to-a-header-f.patch;patchdir=src/3rdparty \
+ file://chromium/0009-chromium-Link-v8-with-libatomic-on-x86.patch;patchdir=src/3rdparty \
+ file://chromium/0010-chromium-icu-use-system-library-only-targets.patch;patchdir=src/3rdparty \
+ file://chromium/0011-chromium-Remove-TRUE-to-prep-landing-of-icu68.patch;patchdir=src/3rdparty \
+ file://chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch;patchdir=src/3rdparty \
+"
+
+# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based
+# 87-based.meta-qt5.9
+SRC_URI:append:libc-musl = "\
+ file://chromium/0013-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
+ file://chromium/0014-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
+ file://chromium/0015-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
+ file://chromium/0016-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
+ file://chromium/0017-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
+ file://chromium/0018-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
+ file://chromium/0019-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
+ file://chromium/0020-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
+ file://chromium/0021-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \
+ file://chromium/0022-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
+ file://chromium/0023-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
+"
-SRCREV_qtwebengine = "73e76f9e86b3fded45be6b232bdebe75e7136e4a"
-SRCREV_chromium = "48a205f9e054b5cc3e67df2e25382da9460c0015"
+SRCREV_qtwebengine = "c7e716ef1ffd63a8ab1f4dbf879230849eb3b505"
+# this is 3 commits ahead of what submodule in 5.15.10 uses (caba2fcb0fe8a8d213c4c79d26da3bb88eee61c7), but contains useful fix:
+SRCREV_chromium = "ecc2bb74f1f7140fc52650042299be18e826b27b"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
@@ -171,10 +202,13 @@ INSANE_SKIP:${PN} += "textrel"
# First patch skips "python2" dependency checks for the pdf module
# Second patch repairs a failing build of the `gn` buildtool due to missing (host) libstdc++
+# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15-qtpdf
+# 5.15-qtpdf.meta-qt5.1
SRC_URI += " \
file://0001-configure.json-remove-python2-dependency.patch \
file://0002-gn.pro-do-not-try-to-statically-link-stdc.patch \
"
+SRC_URI:append:runtime-llvm = " file://0003-Fix-build-with-clang.patch"
# These flags below go more into detail than qtwebengine's documentation
PACKAGECONFIG[no-core] = "-no-build-qtwebengine-core,,"