aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtscxml_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtscxml_git.bb')
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
new file mode 100644
index 00000000..d69d00fe
--- /dev/null
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -0,0 +1,22 @@
+LICENSE = "LGPL-3.0 & BSD & GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+ file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+"
+
+require qt5.inc
+require qt5-git.inc
+
+DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
+
+SRCREV = "4704292500b98143eee9b0fb0b6a34a858ed1253"
+
+SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch"
+
+do_install_append_class-nativesdk() {
+ # qml files not needed in nativesdk
+ rm -rf ${D}${OE_QMAKE_PATH_QML}
+}
+
+BBCLASSEXTEND =+ "native nativesdk"