aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwayland-native_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland-native_git.bb27
1 files changed, 26 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwayland-native_git.bb b/recipes-qt/qt5/qtwayland-native_git.bb
index 3be3e510..3ae35b4b 100644
--- a/recipes-qt/qt5/qtwayland-native_git.bb
+++ b/recipes-qt/qt5/qtwayland-native_git.bb
@@ -1,4 +1,29 @@
+require qt5-native.inc
require qt5-git.inc
-require ${PN}.inc
+
+# There are no LGPLv3-only licensed files in this component.
+LICENSE = "BSD & (LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | LGPL-3.0)"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE.LGPL;md5=4193e7f1d47a858f6b7c0f1ee66161de \
+ file://LICENSE.GPL;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
+ file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
+"
+
+QT_MODULE = "${BPN}"
+
+DEPENDS = "qtbase-native wayland-native"
+
+SRC_URI += " \
+ file://0001-Install-the-qtwaylandscanner-tool-to-the-native-side.patch \
+"
+
+do_configure() {
+ ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S}/src/qtwaylandscanner
+}
+
+do_install() {
+ oe_runmake install INSTALL_ROOT=${D}
+}
SRCREV = "d5e7965a87d81e2d7157c785403b0aba681de62a"