aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland_5.3.2+git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwayland_5.3.2+git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland_5.3.2+git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland_5.3.2+git.bb b/recipes-qt/qt5/qtwayland_5.3.2+git.bb
new file mode 100644
index 00000000..bfbeab18
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland_5.3.2+git.bb
@@ -0,0 +1,21 @@
+require qt5-git.inc
+require ${PN}.inc
+
+SRCREV = "98dca3b54f52f08117c1e0d3a1b4826ed12ef23f"
+
+SRC_URI += " \
+ file://0001-examples.pro-include-server-buffer-only-when-buildin.patch \
+"
+
+# this wasn't released, the PV is set just to signify that this SRCREV was tested together
+# with 5.3.2 version of other modules
+PV = "5.3.2"
+DEFAULT_PREFERENCE = "1"
+
+QT_VERSION ?= "5.3.0"
+
+do_install_append() {
+ # do install files created by qtwaylandscanner
+ install ${B}/include/QtCompositor/${QT_VERSION}/QtCompositor/private/qwayland-server-*.h ${D}${OE_QMAKE_PATH_QT_HEADERS}/QtCompositor/${QT_VERSION}/QtCompositor/private
+ install ${B}/include/QtCompositor/${QT_VERSION}/QtCompositor/private/*protocol*.h ${D}${OE_QMAKE_PATH_QT_HEADERS}/QtCompositor/${QT_VERSION}/QtCompositor/private
+}