aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwayland_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwayland_git.bb')
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 28dd2be8..f85fe356 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -44,3 +44,20 @@ BBCLASSEXTEND =+ "native nativesdk"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
+
+# Since version 5.11.2 some private headers are not installed. Work around
+# until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for
+# further details
+do_install_append() {
+ if [ -d "${B}/src/client" ]; then
+ upstream_pv=`echo "${PV}" | sed 's:+git.*::g'`
+ for header in `find ${B}/src/client -name '*wayland-*.h'`; do
+ header_base=`basename $header`
+ dest="${D}${includedir}/QtWaylandClient/$upstream_pv/QtWaylandClient/private/$header_base"
+ if [ ! -e "$dest" ]; then
+ echo "Manual install: $header_base to $dest"
+ install -m 644 "$header" "$dest"
+ fi
+ done
+ fi
+}