aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb13
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index cd79a8a6..1d7fe83f 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -23,6 +23,8 @@ DEPENDS += " \
qtlocation \
libdrm fontconfig pixman openssl pango cairo icu pciutils nss \
libcap \
+ jpeg-native \
+ freetype-native \
gperf-native \
${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa-lib', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcomposite libxcursor libxi libxrandr libxtst', '', d)} \
@@ -43,7 +45,7 @@ SECURITY_STRINGFORMAT = ""
# To use system ffmpeg you need to enable also libwebp, opus, vpx
# Only depenedencies available in oe-core are enabled by default
-PACKAGECONFIG ??= "libwebp libevent libpng \
+PACKAGECONFIG ??= "libevent libpng \
${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}"
PACKAGECONFIG[icu] = "-feature-webengine-system-icu,-no-feature-webengine-system-icu,icu"
@@ -142,7 +144,7 @@ RDEPENDS_${PN}-examples += " \
qtdeclarative-qmlplugins \
"
-QT_MODULE_BRANCH_CHROMIUM = "80-based"
+QT_MODULE_BRANCH_CHROMIUM = "83-based"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15
# 5.15.meta-qt5.7
@@ -163,7 +165,7 @@ SRC_URI += " \
file://chromium/0002-chromium-stack-pointer-clobber.patch;patchdir=src/3rdparty \
file://chromium/0003-chromium-fix-build-with-clang.patch;patchdir=src/3rdparty \
file://chromium/0004-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \
- file://chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch;patchdir=src/3rdparty \
+ file://chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for.patch;patchdir=src/3rdparty \
file://chromium/0006-chromium-aarch64-skia-build-fix.patch;patchdir=src/3rdparty \
file://chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \
file://chromium/0008-chromium-Fix-build-on-32bit-arches-with-64bit-time_t.patch;patchdir=src/3rdparty \
@@ -180,7 +182,6 @@ SRC_URI_append_libc-musl = "\
file://chromium/0016-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
file://chromium/0017-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
file://chromium/0018-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
- file://chromium/0019-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
file://chromium/0020-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
file://chromium/0021-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
file://chromium/0022-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
@@ -190,8 +191,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0026-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "9e4d1eb45d5c6299e79ac3f28282fd76f949980e"
-SRCREV_chromium = "62bc475876cbae17e2e39175fe321780512e5951"
+SRCREV_qtwebengine = "5537ff4437ea7a5f9ea140071343f88bf48deddc"
+SRCREV_chromium = "fb6ab5e483876298235be1c6a6013b426c82b759"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"