aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 148bbdbd..5dad2316 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -30,6 +30,8 @@ DEPENDS += " \
DEPENDS_append_libc-musl = " libexecinfo"
+inherit pkgconfig
+
EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn"
EXTRA_QMAKEVARS_PRE += "CONFIG+=force_debug_info"
@@ -139,6 +141,7 @@ QT_MODULE_BRANCH_CHROMIUM = "69-based"
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
file://0001-Force-host-toolchain-configuration.patch \
+ file://0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch \
"
SRC_URI_append_libc-musl = "\
file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
@@ -157,6 +160,7 @@ SRC_URI += " \
file://chromium/0021-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \
file://chromium/0022-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch;patchdir=src/3rdparty \
file://chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \
+ file://chromium/0013-chromium-breakpad-fix-build-with-glibc-2.34.patch;patchdir=src/3rdparty \
"
SRC_URI_append_libc-musl = "\
@@ -176,8 +180,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0018-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "07fcac049e7b362b703f31ec559f5097f804588e"
-SRCREV_chromium = "92253f4cc04b8fddd238e2fc9309d8c33c8bdc05"
+SRCREV_qtwebengine = "56e97848125329780566db8164c9753872e65f0f"
+SRCREV_chromium = "78831e7aca3f82a0c64499706c8017c13389efa3"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"