aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch')
-rw-r--r--recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch b/recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch
new file mode 100644
index 00000000..39ee847c
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0010-webdriver-libatomic.patch
@@ -0,0 +1,23 @@
+link with libatomic
+
+This fixes build with C11
+
+lib/../Source/WTF/wtf/CMakeFiles/WTF.dir/Assertions.cpp.o:/usr/include/c++/11.0.1/bits/atomic_base.h:520: more undefined references to `__atomic_compare_exchange_1' follow
+| collect2: error: ld returned 1 exit status
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/Source/WTF/wtf/CMakeLists.txt
++++ b/Source/WTF/wtf/CMakeLists.txt
+@@ -245,6 +245,10 @@ if (NOT USE_SYSTEM_MALLOC)
+ list(APPEND WTF_LIBRARIES bmalloc)
+ endif ()
+
++list(APPEND WTF_LIBRARIES
++ -Wl,--as-needed -Wl,-latomic -Wl,--no-as-needed
++)
++
+ list(APPEND WTF_SOURCES
+ unicode/icu/CollatorICU.cpp
+ )