aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qtxmlpatterns/run-ptest6
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
2 files changed, 8 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtxmlpatterns/run-ptest b/recipes-qt/qt5/qtxmlpatterns/run-ptest
new file mode 100644
index 00000000..044f834d
--- /dev/null
+++ b/recipes-qt/qt5/qtxmlpatterns/run-ptest
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+for x in ` awk '{print $1}' tst_list `;do
+ ./${x};
+done
+
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index c7efaf3f..9333be0b 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -1,5 +1,6 @@
require qt5.inc
require qt5-git.inc
+require qt5-ptest.inc
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
@@ -19,3 +20,4 @@ DEPENDS += "qtbase"
SRCREV = "9f7e01b582b1bd83cc6b8a854c510871335e2e74"
BBCLASSEXTEND =+ "native nativesdk"
+