aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5')
-rw-r--r--recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch39
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch b/recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch
new file mode 100644
index 00000000..89014da3
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch
@@ -0,0 +1,39 @@
+From 5f5afe275757efe77ff48debb040e08001ea5907 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Sun, 8 Mar 2020 10:51:48 +0100
+Subject: [PATCH] Remove ninja version test for now - it fails for ninja >=
+ 1.10.x
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+As long as upstream has no better solution, assume we have a ninja version
+recent enough
+
+Fixes:
+| Found ninja from path: /home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-mortsgna-linux-gnueabi/qtwebengine/5.14.1+gitAUTOINC+73d457481c_a9a20127e8-r0/recipe-sysroot-native/usr/bin/ninja
+| + /home/superandy/tmp/oe-core-glibc/work/cortexa7t2hf-neon-vfpv4-mortsgna-linux-gnueabi/qtwebengine/5.14.1+gitAUTOINC+73d457481c_a9a20127e8-r0/recipe-sysroot-native/usr/bin/ninja --version
+| > 1.10.0
+| Ninja version too old
+
+Upstream-Status: Inappropriate [temporary-hack]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ configure.pri | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/configure.pri b/configure.pri
+index 3a144e3f..6c3f29fd 100644
+--- a/configure.pri
++++ b/configure.pri
+@@ -163,8 +163,7 @@ defineTest(qtConfTest_detectNinja) {
+ !isEmpty(ninja) {
+ qtLog("Found ninja from path: $$ninja")
+ qtRunLoggedCommand("$$ninja --version", version)|return(false)
+- contains(version, "1.[7-9].*"): return(true)
+- qtLog("Ninja version too old")
++ return(true)
+ }
+ qtLog("Building own ninja")
+ return(false)
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 1a3fcae5..9ee81562 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -141,6 +141,7 @@ QT_MODULE_BRANCH_CHROMIUM = "69-based"
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
file://0001-Force-host-toolchain-configuration.patch \
+ file://0002-Remove-ninja-version-test-for-now-it-fails-for-ninja.patch \
"
SRC_URI_append_libc-musl = "\
file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \