aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb5
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5.inc1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch10
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtcoap_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtgamepad_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtknx_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb4
-rw-r--r--recipes-qt/qt5/qtlottie_git.bb2
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtpurchasing_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
42 files changed, 50 insertions, 48 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 2a3778cf..ae6a7c2f 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -152,7 +152,8 @@ do_install() {
# remove things unused in nativesdk, we need the headers and libs
rm -rf ${D}${datadir} \
${D}${libdir}/cmake \
- ${D}${libdir}/pkgconfig
+ ${D}${libdir}/pkgconfig \
+ ${D}${libdir}/metatypes \
# Install CMake's toolchain configuration
mkdir -p ${D}${datadir}/cmake/OEToolchainConfig.cmake.d/
@@ -195,4 +196,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "3c7df4a0ff91a833cf77e38ab8ccd65e289242e9"
+SRCREV = "663d00c71697a3383d9b3f3bb42b72c3d8eeaa05"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 05c0df55..2b444ad2 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "bfeba7c431fd7bebbf7163853cb2e6a327e188aa"
+SRCREV = "7d0bcdb027826997b76f84f25e9eb06ea365205c"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index 6f9a83c4..c6d1ea71 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -134,6 +134,7 @@ FILES_${PN} += " \
FILES_${PN}-dev += " \
${OE_QMAKE_PATH_LIBS}/lib*${SOLIBSDEV} \
${OE_QMAKE_PATH_LIBS}/pkgconfig \
+ ${OE_QMAKE_PATH_LIBS}/metatypes \
${OE_QMAKE_PATH_LIBS}/cmake/* \
${OE_QMAKE_PATH_LIBS}/*.prl \
${OE_QMAKE_PATH_LIBS}/*.la \
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index d89a2b40..4dc3b97a 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -143,4 +143,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "3c7df4a0ff91a833cf77e38ab8ccd65e289242e9"
+SRCREV = "663d00c71697a3383d9b3f3bb42b72c3d8eeaa05"
diff --git a/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch b/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
index e0591d2a..48dfbca3 100644
--- a/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
+++ b/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
@@ -1,4 +1,4 @@
-From a080cb3ac2ad24aeb73407c772ed560dc4cb7ef5 Mon Sep 17 00:00:00 2001
+From 35c83da2aadb100be6b4474bbf02d32b78d9ad04 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Tue, 23 Oct 2018 09:54:57 +0300
Subject: [PATCH] Disable ltcg for host_build
@@ -15,7 +15,7 @@ Upstream-Status: Inappropriate [embedded specific]
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mkspecs/features/ltcg.prf b/mkspecs/features/ltcg.prf
-index a94f6d0eeb..3cb01c334d 100644
+index d81f340edd..dc1d196710 100644
--- a/mkspecs/features/ltcg.prf
+++ b/mkspecs/features/ltcg.prf
@@ -1,6 +1,6 @@
@@ -23,6 +23,6 @@ index a94f6d0eeb..3cb01c334d 100644
# Static library but no-static-ltcg enabled: skip LTCG
-} else: CONFIG(release, debug|release) {
+} else: CONFIG(release, debug|release):!host_build {
- # We need fat object files when creating static libraries on some platforms
- # so the linker will know to load a particular object from the library
- # in the first place. On others, we have special ar and nm to create the symbol
+ separate_debug_info {
+ # Evaluate single-$ variable references that have no valid value at mkspec loading time
+ QMAKE_LFLAGS_LTCG_SEPARATE_DEBUG_INFO ~= s/\\$\\{/\$\$\{/
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 044297dd..a3710edf 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -293,4 +293,4 @@ sed -i \
$D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
}
-SRCREV = "3c7df4a0ff91a833cf77e38ab8ccd65e289242e9"
+SRCREV = "663d00c71697a3383d9b3f3bb42b72c3d8eeaa05"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 5a4d079c..9169516a 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "4b534d99fe687c40fb9dd08de6b4f7ebadfb9135"
+SRCREV = "354bda2ae41feb157c890766e2abcbc8be07f101"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
diff --git a/recipes-qt/qt5/qtcoap_git.bb b/recipes-qt/qt5/qtcoap_git.bb
index 98446005..579a7308 100644
--- a/recipes-qt/qt5/qtcoap_git.bb
+++ b/recipes-qt/qt5/qtcoap_git.bb
@@ -11,4 +11,4 @@ PACKAGECONFIG[qtdeclarative] = ",,qtdeclarative"
DEPENDS += "qtbase"
-SRCREV = "a7bfc7ebb30dd45e4692ec38d8b9ede6372939f0"
+SRCREV = "f20d16c3809cf5641d597c2a8de76d945e35fa35"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 6f463733..9f76616b 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,bluez5"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "797a6414bbacb9cdd0a8b4ff1b1751de09119660"
+SRCREV = "d3eb54e30943a69c469732f9184cbbad944fef28"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index ac3cd941..c00f47c9 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "2900ec11a8100e474f3b595848314b894ecb2079"
+SRCREV = "620eeaaa5bf3af1b5c1760042d1c369d21ad2a8f"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 134f232b..22b05f35 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -29,6 +29,6 @@ do_install_append_class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "a428a2199f4ce75d68585cabe3471356933fa404"
+SRCREV = "289c0fdc2cafd79e3178a9cd3cfc6c5bd53c8336"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb
index 1ec882be..9d87920c 100644
--- a/recipes-qt/qt5/qtgamepad_git.bb
+++ b/recipes-qt/qt5/qtgamepad_git.bb
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "9359fd8c0657a80ca5add1fd2ff9a5eb7b75cfa3"
+SRCREV = "e2fe789f1055835c92ece16646edff892e0f4d9c"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index 6a253747..1149fe3e 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -18,4 +18,4 @@ RDEPENDS_${PN}-dev = ""
# http://errors.yoctoproject.org/Errors/Build/44912/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "ec61d1469d0cbfc9c8edb60fe3c78d6702aa79a8"
+SRCREV = "1466b9792e6c61eebb767717a1298f240899e8c3"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 9128ade7..b7540c59 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "0d150412b607680ea6ce79baf60c2d2709d5f057"
+SRCREV = "abfb7b84d33726fa7b5fdff29371569018afdf8f"
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index 7cbcf895..0f07de7c 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "35f6e58cd747a3d19a503c7fa49bb74aeaedd87e"
+SRCREV = "9f8d1c7c333651035a7802f434a6376072173685"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index f9b14834..8c0ccb93 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -35,7 +35,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "741d90b31650d71d7ea7a7cc9e83b1ab36e060c5"
-SRCREV_qtlocation-mapboxgl = "5233c75b3f6c73623c5473b2d6573f31f3ddb4b7"
+SRCREV_qtlocation = "912f7c727a4362c9530804d9bf1fd92062734af1"
+SRCREV_qtlocation-mapboxgl = "d9577fdebe019b19e184b4cac82749ae9ec87afb"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtlottie_git.bb b/recipes-qt/qt5/qtlottie_git.bb
index 7b72601c..e4e896b7 100644
--- a/recipes-qt/qt5/qtlottie_git.bb
+++ b/recipes-qt/qt5/qtlottie_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "98a7aa119107bab9026a4c45dea0e0b0e959af84"
+SRCREV = "e14d6cd4de7e2692da95511e8a2dc53fa30d1cc2"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index e01ea483..bcb26106 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "4e4050fdbdeab6e63c0b55947512a92845872930"
+SRCREV = "c279feb00c3923f8cab8982bdedc3662fa2b43ad"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index c0f99952..99306eea 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "5c0cca78f410e8a89d3216aeba916d73070398f4"
+SRCREV = "e530c303d8d9164888f8d6e1a935b81cda8bf426"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index 2a1bf553..ba3214ce 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "40b0dbbd02fa16396bd27c40fd51f8840d6bfbea"
+SRCREV = "2c954135f7f05aa0f0a05494ce60ab58520afc5d"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index f5596e42..4dac0519 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -18,4 +18,4 @@ SECURITY_STRINGFORMAT = ""
DEPENDS += "qtbase"
-SRCREV = "96be231060829ed8c7afb2c7fd6df78d74417251"
+SRCREV = "220a1cb6c5c7adc1c61f9a086128de178aec8e52"
diff --git a/recipes-qt/qt5/qtpurchasing_git.bb b/recipes-qt/qt5/qtpurchasing_git.bb
index 6577c879..a85f54c0 100644
--- a/recipes-qt/qt5/qtpurchasing_git.bb
+++ b/recipes-qt/qt5/qtpurchasing_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "5abe17167b1236f9efd3ae074dadb7cfd5e1e76e"
+SRCREV = "690fb774ce2c78ff456f85a07c0ebcf3468b8515"
diff --git a/recipes-qt/qt5/qtquick3d_git.bb b/recipes-qt/qt5/qtquick3d_git.bb
index 0851758b..b2d62ce4 100644
--- a/recipes-qt/qt5/qtquick3d_git.bb
+++ b/recipes-qt/qt5/qtquick3d_git.bb
@@ -21,7 +21,7 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick3D/Helpers/meshes/*.mesh \
"
-SRCREV_qtquick3d = "746a7653609a5cbcda6a49213aefef5c0a514f2f"
+SRCREV_qtquick3d = "30862c165996a153a9380ab5fa55768e30eb5c98"
SRCREV_assimp = "5c900d689a5db5637b98f665fc1e9e9c9ed416b9"
SRCREV_FORMAT = "qtquick3d_assimp"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 787a6cfd..97e61fdb 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "611422b5968ceac6cfba034116a3d1e107d8e2df"
+SRCREV = "ec686af14f817cc51323cfb01186f036905789c3"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 0c6997b7..c98349e1 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "e6182202ba0bb93fa62ce1a54159501823046c37"
+SRCREV = "1757766e9812337c0bddffd267baf04c332efd47"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index 1a510f00..e2cabd7c 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -25,6 +25,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "7c5e9803c0a35010e5bdea30ac05819560dd8e90"
+SRCREV = "afa84f528980af599e36c44523d9a489fa708dd7"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 76ba0263..c7c22f46 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -36,4 +36,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "3c20a81bf02902cd57c7a188555cd33359b27f27"
+SRCREV = "4579c6eba8ca323f98b25a5aa8032a771e857c2b"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index eab34409..2592ce5a 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "a84f5f9d10b59606fabbe3448c8e619e6694565a"
+SRCREV = "a49c4f4cb16cd9e79ac97ab0178df0d9e49ec3f5"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.13
# 5.13.meta-qt5.1
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index 79e9257b..f10a939f 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "1560cbe6e0935dcb900be403ed414d293739d5b3"
+SRCREV = "1c4e3b3c81c24a16f5d19934ad671fa4eb047784"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 1548ef3a..b1b4d794 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "bdff94ba65a22cb1edf4be15459c128c5de146bc"
+SRCREV = "2032431ebdf9a2b26ddb6cfb79f7da4bd53fa5f0"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index c696551c..b5e1ca8b 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "dd22f6091527902d92568f6ec2a27e8c8d52f17c"
+SRCREV = "0d28f55d79214e6bd343dc0b7459644168b0c290"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 9187efc2..a5a58a4b 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "ab818cbbeb7acab61eee3a4694457ceba8c35981"
+SRCREV = "5441a4cc3068eec15f01942331dc1aa094883963"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index aff9484a..a5da1ddb 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -40,7 +40,7 @@ EXTRA_QMAKEVARS_PRE_append_class-target = "\
${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=config_clang', 'CONFIG+=config_clang_done CONFIG-=config_clang', d)} \
"
-SRCREV = "6ae18c04ceae3668536ae2016f0b3d1d7cf75b01"
+SRCREV = "51d2ff5dd89bc7747298c93bd00bee908c6fba0e"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 31f75429..8baeea74 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -71,4 +71,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "dbd8eb64fb444c9a8c2658a6d514b32167beca55"
+SRCREV = "212ee5bc24c3e9de63d7e6a615f1a3a47eae0fc3"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 0d8b5b92..432325c2 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -39,7 +39,7 @@ PACKAGECONFIG[wayland-libhybris-egl-server-buffer] = "-feature-wayland-libhybris
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "8d1fedd6781babaf130486e5c7192b0ebc9fb039"
+SRCREV = "957c0f52de83a0efe75b0ab33d1645799b892725"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index 6b13c6e3..c3ec22fc 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "272ff9e83e030e7f8595da1b4850d3883165acfd"
+SRCREV = "237e90ec1cdaf6f91b82e663bd8bfccbaa2603e2"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index aaebc5af..9ef729e2 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -178,8 +178,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0020-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "06a04f4acbde2f6ae966c450014102120b887d6a"
-SRCREV_chromium = "88a931558e2e960eacccb32483713fcc4bbaf433"
+SRCREV_qtwebengine = "09ce1e76716ca660ef6a9b39e4bb0015d03a0793"
+SRCREV_chromium = "939daf833fff3a9901afb6fd65d02e0f057a494a"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
index 890c9123..a2cd29e7 100644
--- a/recipes-qt/qt5/qtwebglplugin_git.bb
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -18,4 +18,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "1714aa0211057e79d1885c5b93d82993fefe1197"
+SRCREV = "e15365c065955e62053441f1b386492da231cc1d"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index c6b312aa..c060af25 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "0964522a491ba3e96742594fec1eeef3a41e00ac"
+SRCREV = "f42b228928c3e51c46bdf0ef855b4832fa59817e"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index 28cc6fa0..3bb26a27 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "b0bfad9b87e57ef3dcec3fe68df9e89a0bda268e"
+SRCREV = "9ba21cdd3079d9534863f120f8ef5e868ecd053d"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index af2f9d22..9b85bd19 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "e80a767b813fc1becc206def56e9a48a01f674e2"
+SRCREV = "d6e4f960f7aa9e934caf9d948aad49101f662864"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index a98c5008..40cdcfbe 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -25,7 +25,7 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "be8f937b9bae96fbfe36135670997b9124b09b24"
+SRCREV = "b45d63e028345956256740307f2788b387188e1f"
BBCLASSEXTEND =+ "native nativesdk"