aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* qt5: update submodulesv5.15.0Mikko Gronoff2020-05-134-4/+4
| | | | | | | | Update qtbase & qtdeclarative for Qt 5.15.0. Task-number: QTBUG-80823 Change-Id: I40b019381bba2390a8353c249acf46a5931f3314 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* qt5: update submodulesv5.15.0-rc2Mikko Gronoff2020-05-1110-76/+12
| | | | | | | | Update to Qt 5.15.0 RC2 Task-number: QTBUG-80823 Change-Id: I5541f9f2ee80ddd667ad809fd034762d9b990800 Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
* qt5: update submodulesv5.15.0-rcMikko Gronoff2020-05-0514-15/+15
| | | | | | | | Update to latest content in Qt 5.15.0 branch. Task-number: QTBUG-83792 Change-Id: I45fd0a2557a0e82aa15656ad025194be1f11ceb8 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* QtWebkit: Set release build by defaultChenxi Mao2020-04-301-0/+1
| | | | | | | | | Current Qtwebkit configuration is debug build by default. Change it to release build to have better performance. Change-Id: Ib5e10bfd62edf79ddc304332ff10fdbe3abf58f0 Reviewed-by: Chenxi Mao <chenxi.mao2013@gmail.com> Reviewed-by: Konstantin Tokarev <annulen@yandex.ru>
* qt5: update submodulesMikko Gronoff2020-04-2840-42/+42
| | | | | | | | Update to latest content in Qt 5.15.0 branch. Task-number: QTBUG-80823 Change-Id: I1f077ce582eb831ccf68b4f2084be9d288ef1a2f Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* Merge remote-tracking branch 'qt/upstream/master' into 5.15Mikko Gronoff2020-04-2338-445/+177
|\ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | - Several modules are actually newer than beta4 in upstream, hence the conflicts with SRCREVs. - Replaced/removed local QPainterPath patches for qwt & creator with upstream ones. - Updated the qtwebkit SRCREV to sync with upstream as it switched to same "5.212" branch as locally already, but kept the riscv patch * upstream/master: d6b6838e qt5: upgrade to 5.15 beta4 05b3e648 qtwebkit: Switch to 5.212 branch abed512f qt5-creator: Upgrade to 4.12 branch 32c62abe qwt-qt5: fix build with Qt 5.15 44fc90ee gstreamer1.0-plugins-good: Reemove inserting qt5 from packageconfig Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qt5-creator_git.bb recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick3d_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebengine/chromium/0003-chromium-fix-build-with-clang.patch recipes-qt/qt5/qtwebengine/chromium/0008-chromium-Fix-build-on-32bit-arches-with-64bit-time_t.patch recipes-qt/qt5/qtwebengine/chromium/0012-chromium-Link-v8-with-libatomic-on-x86.patch recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebkit_git.bb recipes-qt/qwt/qwt-qt5_6.1.4.bb Change-Id: Icf6e747da78059c23568ea00ebbe50b28588aa3f
| * qt5: upgrade to 5.15 beta4Martin Jansa2020-04-2146-74/+74
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebkit: Switch to 5.212 branchKhem Raj2020-04-212-3848/+2
| | | | | | | | | | | | | | Drop py3 support patch as its no longer needed on this branch This is more uptodate branch and has needed fixes to work with Qt 5.15 Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qt5-creator: Upgrade to 4.12 branchKhem Raj2020-04-212-57/+3
| | | | | | | | | | | | | | | | This fixes build with - qt 5.15 QPainterPath changes - Clang-10 Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qwt-qt5: fix build with Qt 5.15Martin Jansa2020-04-142-0/+132
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * gstreamer1.0-plugins-good: Reemove inserting qt5 from packageconfigKhem Raj2020-04-131-1/+0
| | | | | | | | | | | | | | | | | | layers are usually supposed to be inert, but this option automatically inserts itself without any changes due to this bbappend. Its best to leeave this option to end user to enable, defaults are to disable it and let it be as it is. Signed-off-by: Khem Raj <raj.khem@gmail.com>
* | qt5: update submodulesv5.15.0-beta4Mikko Gronoff2020-04-169-10/+10
| | | | | | | | | | | | | | Update to latest content in Qt 5.15 branch. Change-Id: I97774db909f75c9fa84f45e5acc0905521e32173 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* | coin: remove webkit excludeMikko Gronoff2020-04-161-1/+0
| | | | | | | | | | | | | | webkit was updated and builds now Change-Id: I6939f3a53fdb7c59ad282c70e29a422aab991978 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* | qt5: update submodulesMikko Gronoff2020-04-1517-35/+35
| | | | | | | | | | | | | | | | Update to latest content in Qt 5.15 branch Task-number: QTBUG-80823 Change-Id: I72ecac4a29bf1d1f072169d709aa7ecdc895c0e5 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* | Merge remote-tracking branch 'qt/upstream/master' into 5.15Mikko Gronoff2020-04-1569-312/+285
|\ \ | |/ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * Diff in SRCREVs are due checkout from commit vs. checkout from corresponding tag in modules. The content is the same. * metatypes inclusion was a bit different in upstream, synced with upstream * update module_config.yaml * upstream/master: 02930760 qtmultimedia: create /usr/lib/plugins/videoeglvideonode referenced by Qt5MultimediaConfig.cmake b8bcf8cb qt5: upgrade to 5.15 beta3 eac416fe qtdeclarative: bump SRCREV 6558d2b5 nativesdk-qtbase: fix unpackaged files 6b2323f3 qtwebengine: update patches for beta2 20ae10f0 qt5: upgrade to 5.15 beta2 a01de873 qtwebengine: fix QT_MODULE_BRANCH_CHROMIUM b88c292a qtquick3d: Fix branch for fetching assimp submodule df67d5a7 qt3d: update patch to apply a38953a6 qt5: upgrade to latest revisions in 5.15 branch 9a645b02 qtwebengine: update patches for latest 5.15 revision 6cce9817 qtwebengine: update patches for 5.15 50e35581 qtbase: update patches for latest 5.15 revision 9f024a55 qtdeclarative: add dependency on qtdeclarative-native 76125ba8 qt5.inc: package metatypes files f3379951 qtbase: drop xkb, xcb-xinput PACKAGECONFIGs 44405373 qt5: upgrade to latest revisions in 5.15 branch 5e189731 layer: Mark dunfell as the only compatible release 3e759d82 qtwebengine: Fix build with ninja >= 1.10.0 f712bf9f python-pyqt5: remove PyQt_qreal_double from DISABLED_FEATURES 79b0f3a6 python-pyqtchart: remove PyQt_qreal_double from DISABLED_FEATURES 34ae49f8 qtmultimedia: Enable gstreamer support 108b5664 gstreamer1.0-plugins-good: Turn on qt5 packageconfig 4b6ce100 qt5-creator: Inherit mime-xdg 89de99e7 python-{pyqt5,pyqtchart}: fold .inc file into .bb 5d790449 python-pyqt5: drop python 2 recipe b2a958a4 python-pyqt5: disable whole PyQt_OpenGL and QtWidgets, QtQuickWidgets, QtQuick modules without opengl in DISTRO_FEATURES Conflicts: conf/layer.conf recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick3d_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtserialport_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qtvirtualkeyboard_git.bb recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-linux-glibc-make-the-distinction.patch recipes-qt/qt5/qtwebengine/chromium/0018-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebview_git.bb Change-Id: I61a651fd16d475ac0d8bbe119a3e3a8038692726
| * qtmultimedia: create /usr/lib/plugins/videoeglvideonode referenced by ↵Martin Jansa2020-04-071-0/+6
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Qt5MultimediaConfig.cmake * using Qt5MultimediaConfig.cmake fails with error bellow, temorary fix that by creating empty directory CMake Error at /OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5MultimediaConfig.cmake:31 (message): The imported target "Qt5::Multimedia" references the file "/OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/plugins/videoeglvideonode" but this file does not exist. Possible reasons include: * The file was deleted, renamed, or moved to another location. * An install or uninstall procedure did not complete successfully. * The installation package was faulty and contained "/OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5Multimedia_QSGVideoNodeFactory_EGL.cmake" but not all the files it references. Call Stack (most recent call first): /OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5MultimediaConfig.cmake:244 (_qt5_Multimedia_check_file_exists) /OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5Multimedia_QSGVideoNodeFactory_EGL.cmake:5 (_populate_Multimedia_plugin_properties) /OE/build/luneos-master/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.camera/0.0.2-1+gitAUTOINC+a407b0443e-r0/recipe-sysroot/usr/lib/cmake/Qt5Multimedia/Qt5MultimediaConfig.cmake:253 (include) CMakeLists.txt:43 (find_package) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qt5: upgrade to 5.15 beta3Martin Jansa2020-04-0612-13/+13
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtdeclarative: bump SRCREVMartin Jansa2020-04-061-1/+1
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * nativesdk-qtbase: fix unpackaged filesMartin Jansa2020-04-031-0/+1
| | | | | | | | | | | | | | | | | | | | | | * fixes: ERROR: nativesdk-qtbase-5.14.99+5.15-beta2+gitAUTOINC+f515ca5dcd-r0 do_package: QA Issue: nativesdk-qtbase: Files/directories were installed but not shipped in any package: /usr/local/oecore-x86_64/sysroots/x86_64-oesdk-linux/usr/lib/metatypes /usr/local/oecore-x86_64/sysroots/x86_64-oesdk-linux/usr/lib/metatypes/qt5core_metatypes.json Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. nativesdk-qtbase: 2 installed and not shipped files. [installed-vs-shipped] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: update patches for beta2Martin Jansa2020-04-0331-94/+51
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qt5: upgrade to 5.15 beta2Martin Jansa2020-04-0326-27/+27
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: fix QT_MODULE_BRANCH_CHROMIUMMartin Jansa2020-04-021-1/+1
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtquick3d: Fix branch for fetching assimp submoduleKhem Raj2020-03-301-1/+1
| | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qt3d: update patch to applyMartin Jansa2020-03-262-7/+7
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qt5: upgrade to latest revisions in 5.15 branchMartin Jansa2020-03-1835-36/+36
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: update patches for latest 5.15 revisionMartin Jansa2020-03-1829-63/+63
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: update patches for 5.15Martin Jansa2020-03-1829-37/+37
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtbase: update patches for latest 5.15 revisionMartin Jansa2020-03-1825-107/+72
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtdeclarative: add dependency on qtdeclarative-nativeMartin Jansa2020-03-181-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * fixes: | /OE/build/luneos-zeus/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtdeclarative/5.14.99+gitAUTOINC+f7647d5ada-r0/recipe-sysroot-native/usr/bin/qmake -install qinstall /OE/build/luneos-zeus/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtdeclarative/5.14.99+gitAUTOINC+f7647d5ada-r0/build/src/qml/qt5qml_metatypes.json ../../lib/metatypes/qt5qml_metatypes.json | /OE/build/luneos-zeus/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtdeclarative/5.14.99+gitAUTOINC+f7647d5ada-r0/recipe-sysroot-native/usr/bin/qmltyperegistrar --generate-qmltypes=plugins.qmltypes --import-name=QtQml --major-version=2 --minor-version=15 --foreign-types=/OE/build/luneos-zeus/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtdeclarative/5.14.99+gitAUTOINC+f7647d5ada-r0/recipe-sysroot/usr/lib/metatypes/qt5network_metatypes.json,/OE/build/luneos-zeus/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtdeclarative/5.14.99+gitAUTOINC+f7647d5ada-r0/recipe-sysroot/usr/lib/metatypes/qt5core_metatypes.json --dependencies=/OE/build/luneos-zeus/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtdeclarative/5.14.99+gitAUTOINC+f7647d5ada-r0/git/src/qml/dependencies.json --private-includes -o qt5qml_qmltyperegistrations.cpp qt5qml_metatypes.json | make[2]: /OE/build/luneos-zeus/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtdeclarative/5.14.99+gitAUTOINC+f7647d5ada-r0/recipe-sysroot-native/usr/bin/qmltyperegistrar: Command not found | make[2]: *** [Makefile:1680: qt5qml_qmltyperegistrations.cpp] Error 127 | make[2]: *** Waiting for unfinished jobs.... | make[2]: Leaving directory /OE/build/luneos-zeus/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtdeclarative/5.14.99+gitAUTOINC+f7647d5ada-r0/build/src/qml | make[1]: *** [Makefile:102: sub-qml-make_first-ordered] Error 2 | make[1]: Leaving directory /OE/build/luneos-zeus/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtdeclarative/5.14.99+gitAUTOINC+f7647d5ada-r0/build/src | make: *** [Makefile:50: sub-src-make_first] Error 2 | WARNING: exit code 1 from a shell command. | NOTE: recipe qtdeclarative-5.14.99+gitAUTOINC+f7647d5ada-r0: task do_compile: Failed Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qt5.inc: package metatypes filesMartin Jansa2020-03-181-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * enabled since qtbase commit: commit c5e9d7e504172707f7705d03ae27006c45eb5eac Author: Ulf Hermann <ulf.hermann@qt.io> Date: Wed Aug 28 16:09:25 2019 +0200 Generate metatypes.json for QtCore, QtGui, and QtWidgets These libraries contain types which are exposed to QML from qtdeclarative. Change-Id: Ie0edaef94fcb40074b6f6b2ea1a1c3a77ed3e9a9 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> * fixes: ERROR: qtbase-5.14.99+gitAUTOINC+2e7a28958d-r0 do_package: QA Issue: qtbase: Files/directories were installed but not shipped in any package: /usr/lib/metatypes /usr/lib/metatypes/qt5gui_metatypes.json /usr/lib/metatypes/qt5core_metatypes.json /usr/lib/metatypes/qt5widgets_metatypes.json Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. qtbase: 4 installed and not shipped files. [installed-vs-shipped] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtbase: drop xkb, xcb-xinput PACKAGECONFIGsMartin Jansa2020-03-181-4/+2
| | | | | | | | | | | | | | | | | | | | | | * removed from qtbase in: commit 60588e1a5dd9b10803e078c741271cbe5713a51b Author: Gatis Paeglis <gatis.paeglis@qt.io> Date: Tue Feb 19 10:09:19 2019 +0100 3rdparty: remove xcb libs and bump minimal required version to 1.11 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qt5: upgrade to latest revisions in 5.15 branchMartin Jansa2020-03-1841-44/+43
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * layer: Mark dunfell as the only compatible releaseMartin Jansa2020-03-181-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * there are couple things people need to provide to even parse meta-qt5 dunfell branch with older than dunfell release of oe-core so I don't want to mark it as compatible, people who understand how to provide these missing bits will know how to override LAYERSERIES_COMPAT_qt5-layer from their own layer (which needs to be parsed before meta-qt5 layer - I suggest to use something like separate meta-qt5-compat layer) the required work arounds (these are the examples to build dunfell branch from zeus: 1) mime-xdg.bbclass, e.g.: https://github.com/webOS-ports/meta-webos-ports/commit/e57440cb97b210e86991dd0ff2ec53c50d6e0494 2) gstreamer1.0-plugins-good PACKAGECONFIG: https://github.com/webOS-ports/meta-webos-ports/commit/75fd06799bf32eca6700bdf6066d509cf36f3049 3) meta-python2: https://github.com/webOS-ports/meta-webos-ports/commit/57f3f6f20b8c9911042abf0cbf2983df97eb8465 4) features_check.bbclass: https://github.com/webOS-ports/meta-webos-ports/commit/fb3e94ba4a200eaba989a2871a4a5344e2162278 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: Fix build with ninja >= 1.10.0Andreas Müller2020-03-135-7/+47
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * For now just skip version check. Looked into: ninja came from meta-oe to oe-core with: commit fc3aef67a95a90e9a485c6b0e93db8cdeab5d3ab Author: Khem Raj <raj.khem@gmail.com> Date: Thu Jul 27 21:52:12 2017 -0700 ninja: Add recipe llvm is using it, therefore move it from meta-oe Signed-off-by: Khem Raj <raj.khem@gmail.com> That was in rocko release cycle. So the assumption we have a ninja decent enough should be acceptable. * and since the upgrade to ninja-1.10.0 in: commit d1cd957cea29f3ab111ae752bc9ad75a1324c255 Author: Upgrade Helper <auh@auh.yoctoproject.org> Date: Fri Feb 21 14:45:35 2020 -0800 ninja: upgrade 1.9.0 -> 1.10.0 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> the do_configure task fails with: | ERROR: Feature 'webengine-system-ninja' was enabled, but the pre-condition 'tests.webengine-ninja' failed. * Looked into qtwebengine current dev branch: There is no solution yet. So as soon as upstream offers a better solution most likely this patch will not apply any more and has to be removed then. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
| * python-pyqt5: remove PyQt_qreal_double from DISABLED_FEATURESArtem Panfilov2020-03-131-2/+0
| | | | | | | | | | | | Since Qt 5.2.0 the qreal is double (see change d8bf317546bc in qtbase.git). Signed-off-by: Artem Panfilov <panfilov.artyom@gmail.com>
| * python-pyqtchart: remove PyQt_qreal_double from DISABLED_FEATURESArtem Panfilov2020-03-131-2/+0
| | | | | | | | | | | | Since Qt 5.2.0 the qreal is double (see change d8bf317546bc in qtbase.git). Signed-off-by: Artem Panfilov <panfilov.artyom@gmail.com>
| * qtmultimedia: Enable gstreamer supportKhem Raj2020-03-131-1/+2
| | | | | | | | | | | | This helps qt5everywheredemo to play sample videos Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * gstreamer1.0-plugins-good: Turn on qt5 packageconfigKhem Raj2020-03-131-5/+1
| | | | | | | | | | | | qt5 is already defined in oe-core, therefore no need to define it here Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qt5-creator: Inherit mime-xdgKhem Raj2020-03-131-2/+2
| | | | | | | | | | | | | | Fixes QA warning ERROR: QA Issue: package contains desktop file with key 'MimeType' but does not inhert mime-xdg: qt5-creator path '/work/cortexa7t2hf-neon-vfpv4-yoe-linux-musleabi/qt5-creator/4.9.2+gitAUTOINC+8181363fa9-r0/packages-split/qt5-creator/usr/share/applications/org.qt-project.qtcreator.desktop' [mime-xdg] Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * python-{pyqt5,pyqtchart}: fold .inc file into .bbMartin Jansa2020-02-194-131/+123
| | | | | | | | | | | | * drop 2nd DEPENDS assignment from python-pyqtchart.inc Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * python-pyqt5: drop python 2 recipeMartin Jansa2020-02-191-12/+0
| | | | | | | | | | | | | | | | | | | | | | | | * sip-native was already removed from meta-oe and wasn't resurected in meta-python2 so even with meta-python2 layer included this recipe cannot be built: ERROR: Nothing PROVIDES 'sip' (but /OE/build/oe-core/meta-qt5/recipes-python/pyqt5/python-pyqt5_5.13.2.bb DEPENDS on or otherwise requires it). Close matches: sip3 ERROR: Required build target 'python-pyqt5' has no buildable providers. Missing or unbuildable dependency chain was: ['python-pyqt5', 'sip'] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * python-pyqt5: disable whole PyQt_OpenGL and QtWidgets, QtQuickWidgets, ↵Martin Jansa2020-02-192-4/+2
| | | | | | | | | | | | | | | | | | | | QtQuick modules without opengl in DISTRO_FEATURES * fixes: sip: QOpenGLFramebufferObject is undefined in default nodistro setup without opengl in DISTRO_FEATURES Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* | Merge remote-tracking branch 'qt/5.14' into 5.15Mikko Gronoff2020-04-141-2/+2
|\ \ | | | | | | | | | | | | | | | | | | | | | | | | | | | b2c812bf coin: update poky to 3.1_M3 from master 1aa8366b (tag: v5.14.2) qtbase: update module 6d8b91fe qt5: update submodules cbf2529a qt5: update submodules ef88f723 qt5: update submodules Change-Id: I5923d74d8a0481ebcae11a06cb507ead9e73f87a
| * | coin: update poky to 3.1_M3 from master5.14Mikko Gronoff2020-04-111-2/+2
| | | | | | | | | | | | | | | | | | | | | - Also update to latest revision in meta-oe (master) Change-Id: I59c4f48d4e3e8066dfff42dffdbe199678079ccf Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
| * | qtbase: update modulev5.14.2Mikko Gronoff2020-03-283-3/+3
| | | | | | | | | | | | | | | | | | | | | | | | Update to latest revision in Qt 5.14.2 branch. Task-number: QTBUG-81892 Change-Id: Iecd5b27789d8ed7d4d15f4a450dae0edd3778bfb Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
| * | qt5: update submodulesMikko Gronoff2020-03-255-6/+6
| | | | | | | | | | | | | | | | | | | | | | | | Update to latest content in Qt 5.14.2 branch. Task-number: QTBUG-81892 Change-Id: I418aa84295675f03461da69d443f69e2f27db391 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
| * | qt5: update submodulesMikko Gronoff2020-03-2314-15/+15
| | | | | | | | | | | | | | | | | | | | | | | | Update to latest content in Qt 5.14.2 branch. Task-number: QTBUG-81892 Change-Id: I9c193d37ded2e4902e65c6dfcf2e7c388eca1971 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
| * | qt5: update submodulesMikko Gronoff2020-03-1734-35/+35
| | | | | | | | | | | | | | | | | | | | | | | | Update to latest content in Qt 5.14.2 branch. Task-number: QTBUG-81892 Change-Id: I0285c08134b4adc1c1d3e7edcfdbdaf550748969 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* | | meta-qt5: Support latest Yocto projectChenxi Mao2020-04-141-1/+1
| | | | | | | | | | | | | | | | | | Fixes: QTBUG-83460 Change-Id: If00f0bdfb96a423111055a82578def7978621c8f Reviewed-by: Konstantin Tokarev <annulen@yandex.ru>
* | | QTWebkit: Support RISC-V ISA on QTwebkitChenxi Mao2020-04-132-1/+87
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | There are 3 changes to support RISC-V 1. Add a patch to support RISC-V CPU 2. Disable JIT as mips/ppc did Change-Id: I612428194c98acf0f18cec180816caa4e32ece2a Reviewed-by: Chenxi Mao <chenxi.mao2013@gmail.com> Reviewed-by: Konstantin Tokarev <annulen@yandex.ru>