aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* qt5: update submodules for LTS 5.15.7HEADlts-5.15Jani Suonpera12 hours10-10/+10
| | | | | | | Task-number: QTBUG-96316 Change-Id: Ic3ce9cf21b392765e8914122b9587fe3781f587a Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* coin: add yocto branches Hardknott and Honister to Coin integrationJani Suonpera6 days2-23/+37
| | | | | | | | - Configure build targets Hardknott and Honister. Task-number: QTBUG-96439 Change-Id: I97dd2ac622adbf9cde051ffab3d40c279472eca0 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* qtwebengine: fix override syntax changesJani Suonpera7 days1-2/+2
| | | | | | Task-number: QTBUG-96439 Change-Id: I498d9e9686715792c0a991e5abf9ffcdfb330b96 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* Fix Fuzz patch with qt5-creatorJani Suonpera7 days5-23/+24
| | | | | | Task-number: QTBUG-96439 Change-Id: I920de6a5924a258b02de9ea6a594c3fce14e9d95 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* Merge remote-tracking branch 'github/master' into lts-5.15Jani Suonpera11 days74-260/+450
|\ | | | | | | | | Task-number: QTBUG-96310 Change-Id: Iec7ca30851b8e4d172faa0066685259d050bfd74
| * qtwebkit: Inherit pkgconfigupstream/masterupstream/jansa/honisterupstream/honisterKhem Raj2021-09-271-0/+2
| | | | | | | | | | | | | | Fixes Could NOT find LibXslt: Found unsuitable version "", but required is at Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * libqofonoext: Inherit pkgconfigKhem Raj2021-09-271-1/+1
| | | | | | | | | | | | | | Fixes Project ERROR: qofono-qt5 development package not found Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtgamepad: inherit pkgconfigKhem Raj2021-09-271-0/+2
| | | | | | | | | | | | | | Fixes ERROR: Feature 'sdl2' was enabled, but the pre-condition 'libs.sdl2' failed. Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtwayland: Inherit pkgconfigKhem Raj2021-09-271-0/+2
| | | | | | | | | | | | | | Fixes ERROR: Feature 'xcomposite-egl' was enabled, but the pre-condition 'features.wayland-client && features.opengl && features.egl && features.xlib && libs.xcomposite && features.egl_x11' failed. Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtwayland: Fix build break with clang/libc++Khem Raj2021-09-212-1/+33
| | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtwebengine: inherit pkgconfigMartin Jansa2021-09-211-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | * Newer oe-core doesn't pull many default dependencies anymore: https://lists.openembedded.org/g/openembedded-core/message/156185 add explicit dependency on pkgconfig through pkgconfig.bbclass as we're using it here. * fixes: | sed: can't read /OE/build/luneos-honister/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtwebengine/5.15.4+gitAUTOINC+dd7f7a9166_7aad021f2e-r0/image/usr/lib/pkgconfig/Qt5WebEngineCore.pc: No such file or directory because without pkgconfig detected this file isn't created during the build Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtmultimedia: inherit pkgconfigMartin Jansa2021-09-211-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | * some features enabled with PACKAGECONFIG need pkgconfig to be detected correctly * fixes: | Checking for libresourceqt5... ERROR: Error calling /OE/build/luneos-honister/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtmultimedia/5.15.2+gitAUTOINC+fd30913d46-r0/recipe-sysroot-native/usr/bin/qmake -makefile -o Makefile QT_BUILD_PARTS-=examples QT_BUILD_PARTS-=tests /OE/build/luneos-honister/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtmultimedia/5.15.2+gitAUTOINC+fd30913d46-r0/git/qtmultimedia.pro -- -alsa -gstreamer 1.0 -no-feature-openal -pulseaudio | no | Done running configuration tests. ... | ERROR: Feature 'gstreamer_1_0' was enabled, but the pre-condition 'libs.gstreamer_1_0' failed. | | ERROR: Feature 'pulseaudio' was enabled, but the pre-condition 'libs.pulseaudio' failed.
| * maliit-framework-qt5: inherit pkgconfigMartin Jansa2021-09-211-1/+1
| | | | | | | | | | | | | | | | * fixes: | Reading /OE/build/luneos-honister/webos-ports/tmp-glibc/work/core2-64-webos-linux/maliit-framework-qt5/0.99.0+gitAUTOINC+62bd54bcde-r0/git/connection/connection.pro [/OE/build/luneos-honister/webos-ports/tmp-glibc/work/core2-64-webos-linux/maliit-framework-qt5/0.99.0+gitAUTOINC+62bd54bcde-r0/build/connection] | sh: 1: pkg-config: not found | sh: 1: pkg-config: not found | WARNING: install_services.path is not defined: install target not created
| * qtbase: inherit pkgconfigMartin Jansa2021-09-211-0/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * some features enabled with PACKAGECONFIG need pkgconfig to be detected correctly * fixes: Checking for pkg-config... test config.qtbase.tests.pkg-config FAILED ... Trying source 0 (type pkgConfig) of library dbus ... pkg-config use disabled globally. ... ERROR: Feature 'pkg-config' was enabled, but the pre-condition 'tests.pkg-config' failed. ERROR: Feature 'glib' was enabled, but the pre-condition 'libs.glib' failed. ERROR: Feature 'kms' was enabled, but the pre-condition 'libs.drm' failed. ERROR: Feature 'gbm' was enabled, but the pre-condition 'libs.gbm' failed. ERROR: Feature 'mtdev' was enabled, but the pre-condition 'libs.mtdev' failed. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: fix build with glibc-2.34Martin Jansa2021-08-0414-24/+170
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtsvg: fix CVE-2021-3481Kai Kang2021-08-042-0/+75
| | | | | | | | | | | | | | | | | | | | | | | | Backport and squash commits 85b70a721695991e8a5bbe4aa52e5320e170e90c and bfd6ee0d8cf34b63d32adf10ed93daa0086b359f from qtsvg upstream to fix CVE-2021-3481. Ref: https://security-tracker.debian.org/tracker/CVE-2021-3481 Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * layer.conf: Update to honisterMartin Jansa2021-08-031-1/+1
| | | | | | | | | | | | | | This marks the layers as compatible with honister now they use the new override syntax. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * Convert to new override syntaxMartin Jansa2021-08-0357-245/+245
| | | | | | | | | | | | | | | | | | | | This is the result of automated script (0.9.0) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* | qt5: update submodules for LTS 5.15.7Jani Suonpera13 days11-12/+12
| | | | | | | | | | | | | | Task-number: QTBUG-96316 Change-Id: I9eb18d001b900a408efed2bdb1e2d6dfb45cad2a Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
* | qt5: update submodules for LTS 5.15.7Jani Suonpera2021-09-2445-76/+46
| | | | | | | | | | | | | | Task-number: QTBUG-96316 Change-Id: I72252f42808c5ce23337a210bed0fb1e49c9a2a5 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
* | Merge commit '10f3673f' into lts-5.15Jani Suonpera2021-09-238-138/+92
|\ \ | |/ | | | | | | | | | | | | 10f3673f is last SHA1 in upstream master, which does not include Yocto branch Honister. Task-number: QTBUG-96310 Change-Id: I6c9cb67693d8594d727d91e559b190db633a0f67
| * qt5-creator: upgrade 4.15.0 -> 4.15.2 and fix build with clang/llvm 13+Andreas Müller2021-07-233-2/+85
| | | | | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
| * qtwayland: Check for wayland feature for enabling wayland-eglKhem Raj2021-06-231-1/+1
| | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtwebengine: Add missing dbus dependencyPhilipp Zabel2021-06-011-0/+1
| | | | | | | | | | | | | | | | | | | | | | QtWebEngine has a hard dependency on D-Bus, which is currently fulfilled indirectly via the pulseaudio dependency. As soon as pulseaudio is disabled via DISTRO_FEATURES_BACKFILL_CONSIDERED, building QtWebEngine fails. Add a direct dbus dependency to qtwebengine_git.bb to fix this. Signed-off-by: Philipp Zabel <p.zabel@pengutronix.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * cmake_qt5: Add correct qtbase DEPENDSAndreas Müller2021-05-311-1/+4
| | | | | | | | | | | | | | | | | | | | | | Discussion started at [1] To start a proper fix, set qtbase dependencies depending on target. [1] https://github.com/Freescale/meta-freescale/issues/798 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qwt-qt5: upgrade 6.1.4 -> 6.1.5Andreas Müller2021-05-192-134/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Backported patch can go ========= Qwt 6.1.5 ========= 1) Maintenance - Avoid using some of the deprecated Qt APIs - Missing includes of QPainterPath ( Qt 5.15 ) added - QwtPlotSpectroCurve: missing public inheritance - QwtPlotTradingCurve: missing public inheritance 2) Bug fixes - QwtLinearColorMap: handling of alpha values in color stops fixed - QwtPlotRasterItem: missing color table initialization for QImage::Format_Indexed8 - QwtScaleWidget: missing QEvent::LayoutRequest added - QwtSetSample: bound rectangle fixed for empty sets Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
* | Merge remote-tracking branch qt/upstream/master' into lts-5.15Jani Suonpera2021-09-2155-114/+777
|\ \ | |/ | | | | | | Task-number: QTBUG-96310 Change-Id: I3c129d5b6739f699eb00e188b8f60c12ce931641
| * qtwebengine: few more fixes for gcc-11Martin Jansa2021-05-102-6/+31
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: lower MODULE_VERSION to 5.15.2Martin Jansa2021-05-105-8/+43
| | | | | | | | | | | | | | | | | | | | * as we cannot upgrade all modules past 5.15.2 due to license change and the branches for 5.15.4 not available publicly, but qtwebengine and the chromium bits which are probably most important for security fixes are available and hopefully we can use them for non-commercial use Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: upgrade to latest 5.15 and 87-based, fix build with gcc-11Martin Jansa2021-05-1028-70/+122
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: add dependency on nodejs-nativeMartin Jansa2021-05-081-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * it's mandatory since this commit: commit c9d902ca6ca3b1aa2e2762329d18c226d26520af Author: Allan Sandfeld Jensen <allan.jensen@qt.io> Date: Fri Nov 6 09:16:15 2020 +0100 Adaptations for Chromium 87 * unfortunatelly missing this dependency only shows an warning in do_configure: Note: The following modules are not being compiled in this configuration: webenginecore webengine webenginewidgets WARNING: Nodejs is required to build QtWebEngine. WARNING: QtWebEngine will not be built. and then it fails in do_install with: make[1]: Leaving directory '/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.15.3+gitAUTOINC+f121523512_9406a89a9d-r0/build/src' sed: can't read /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.15.3+gitAUTOINC+f121523512_9406a89a9d-r0/image/usr/lib/pkgconfig/Qt5WebEngineCore.pc: No such file or directory WARNING: exit code 2 from a shell command. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: remove PACKAGECONFIG for jsoncpp and protobufMartin Jansa2021-05-081-2/+0
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | * removed in: commit ed0f3c2ef0f17c82f9ba1e8b687f46f468c705c7 Author: Allan Sandfeld Jensen <allan.jensen@qt.io> Date: Fri Jan 15 15:38:14 2021 +0100 Remove configure options that doesn't work They are just confusing users. * fixes: ERROR: Enabling/Disabling unknown feature 'webengine-system-jsoncpp'. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebengine: upgrade to 5.15.4 with chromium-87Martin Jansa2021-05-0832-520/+135
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qt5-creator: upgrade 4.14.2 -> 4.15.0Andreas Müller2021-05-082-49/+3
| | | | | | | | | | | | | | * 4.15.0 build fine with gcc11 * backported patch can go - it is upstream Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
| * qt5-creator: upgrade 4.14.0 -> 4.14.2Andreas Müller2021-04-291-2/+2
| | | | | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
| * qt5-creator: Fix build with LLVM 12 / clang PACKAGECONFIG enabledAndreas Müller2021-04-292-0/+46
| | | | | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
| * qtquickcontrols2: Fix broken Menu slipping out of screen for 2nd+ openAndreas Müller2021-04-162-0/+130
| | | | | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
| * qtwebengine: Fix build with GCC 11Khem Raj2021-04-102-0/+24
| | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtwebengine: Add unconditional dep on libxkbcommonKhem Raj2021-04-101-1/+1
| | | | | | | | | | | | | | It seems qtwebengine 5.15.1+ wants this regardless of X11 being in distro features Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * ogl-runtime: Fix build on ppc64Khem Raj2021-04-102-0/+60
| | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtwebkit: Disable bmalloc on mips/ppc/riscvKhem Raj2021-04-101-3/+4
| | | | | | | | | | | | | | This is needed along when JIT is disabled see https://bugs.webkit.org/attachment.cgi?id=342881&action=diff Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * layer.conf: update LAYERSERIES_COMPAT for hardknottMartin Jansa2021-03-171-1/+1
| | | | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
| * qtwebkit: Fix build with gcc11/riscvKhem Raj2021-03-102-0/+26
| | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qt3d: Fix build on riscv/gcc11Khem Raj2021-03-102-0/+30
| | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtwebkit: Disable gold linker for riscv/ppc/mipsKhem Raj2021-03-101-2/+3
| | | | | | | | | | | | | | gold linker seems to not link the shared lib properly as it results in textrels on these arches. So fallback to bfd linker. Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qt5-creator: Fix parse with latest meta-clangAndreas Müller2021-03-051-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Since meta-clang's commit d38888ea80965206c1d2eab9958db1ff980c56c4 Author: Zoltán Böszörményi <zboszor@pr.hu> Date: Thu Feb 18 04:29:49 2021 -0500 clang: Merge llvm-common into clang Signed-off-by: Zoltán Böszörményi <zboszor@pr.hu> parsing fails with: | ERROR: Nothing PROVIDES 'llvm-common' (but /home/superandy/data/oe-core/sources/meta-qt5/recipes-qt/qt5/qt5-creator_git.bb DEPENDS on or otherwise requires it Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
| * qtdeclarative: Another fix for gcc11Khem Raj2021-03-042-0/+31
| | | | | | | | | | | | This was left out since v1 not v2 of the prior patch was merged. Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtdeclarative: Fix build with gcc11Khem Raj2021-03-042-0/+33
| | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtbase: Fix build with gcc-11Khem Raj2021-03-044-0/+51
| | | | | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
| * qtbase: Define OE_QMAKE_OBJCOPY for linux-oe-g++Dan Christensen2021-03-024-13/+18
| | | | | | | | | | | | | | | | This is useful when QMake has CONFIG+=separate_debug_info which is often not during the actual bitbake builds but when using an eSDK produced by the meta-toolchain-qt5 recipe. Signed-off-by: Dan Christensen <opello@opello.org>