aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-01-31 13:41:47 +0000
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-02-01 09:33:21 +0000
commit0f6de61a4b9649ebef7dc88aa8a3cb9bac230c6e (patch)
tree3ae3460bda4184569b8fc0e4cff6c8262b1e9715
parentc800414eba7a0cdfe2eb399332d49ee60a69657a (diff)
qt6-cmake: inherit pkgconfig
Static build needs pkgconfig for every Qt module. Include it already in qt6-cmake class instead of in each individual module. Change-Id: I065382ee49d6b40b76ede9e632d17221451de8d1 Reviewed-by: Pasi Petäjäjärvi <pasi.petajajarvi@qt.io> (cherry picked from commit cbac31ee9090e3e0e1c81b7e1458410deece1331) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--classes/qt6-cmake.bbclass2
-rw-r--r--recipes-qt/qt6/qtbase_git.bb2
-rw-r--r--recipes-qt/qt6/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt6/qtinterfaceframework_git.bb2
-rw-r--r--recipes-qt/qt6/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt6/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt6/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt6/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt6/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt6/qtwebengine.inc2
10 files changed, 10 insertions, 10 deletions
diff --git a/classes/qt6-cmake.bbclass b/classes/qt6-cmake.bbclass
index 918122f..447dab5 100644
--- a/classes/qt6-cmake.bbclass
+++ b/classes/qt6-cmake.bbclass
@@ -1,4 +1,4 @@
-inherit cmake python3native perlnative qt6-paths
+inherit cmake python3native perlnative pkgconfig qt6-paths
DEPENDS:prepend = "qtbase-native "
diff --git a/recipes-qt/qt6/qtbase_git.bb b/recipes-qt/qt6/qtbase_git.bb
index 3a7b741..dc612fb 100644
--- a/recipes-qt/qt6/qtbase_git.bb
+++ b/recipes-qt/qt6/qtbase_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.QT-LICENSE-AGREEMENT;md5=f383149f021dd9099dd49628e3916808 \
"
-inherit qt6-cmake pkgconfig
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
diff --git a/recipes-qt/qt6/qtconnectivity_git.bb b/recipes-qt/qt6/qtconnectivity_git.bb
index ab6ac10..51b17da 100644
--- a/recipes-qt/qt6/qtconnectivity_git.bb
+++ b/recipes-qt/qt6/qtconnectivity_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-inherit qt6-cmake pkgconfig
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
diff --git a/recipes-qt/qt6/qtinterfaceframework_git.bb b/recipes-qt/qt6/qtinterfaceframework_git.bb
index ba3d327..5617565 100644
--- a/recipes-qt/qt6/qtinterfaceframework_git.bb
+++ b/recipes-qt/qt6/qtinterfaceframework_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-inherit qt6-cmake pkgconfig
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
diff --git a/recipes-qt/qt6/qtmultimedia_git.bb b/recipes-qt/qt6/qtmultimedia_git.bb
index 6d77955..764290a 100644
--- a/recipes-qt/qt6/qtmultimedia_git.bb
+++ b/recipes-qt/qt6/qtmultimedia_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-inherit qt6-cmake pkgconfig
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
diff --git a/recipes-qt/qt6/qtsensors_git.bb b/recipes-qt/qt6/qtsensors_git.bb
index 28b6fc3..89df659 100644
--- a/recipes-qt/qt6/qtsensors_git.bb
+++ b/recipes-qt/qt6/qtsensors_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
"
-inherit qt6-cmake pkgconfig
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
diff --git a/recipes-qt/qt6/qtserialport_git.bb b/recipes-qt/qt6/qtserialport_git.bb
index b1d2504..1fe3356 100644
--- a/recipes-qt/qt6/qtserialport_git.bb
+++ b/recipes-qt/qt6/qtserialport_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
"
-inherit qt6-cmake pkgconfig
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
diff --git a/recipes-qt/qt6/qtvirtualkeyboard_git.bb b/recipes-qt/qt6/qtvirtualkeyboard_git.bb
index ec0ac8e..499fe3c 100644
--- a/recipes-qt/qt6/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt6/qtvirtualkeyboard_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=a22d0be1ce2284b67950a4d1673dd1b0 \
"
-inherit qt6-cmake pkgconfig
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
diff --git a/recipes-qt/qt6/qtwayland_git.bb b/recipes-qt/qt6/qtwayland_git.bb
index 46490a8..ee52062 100644
--- a/recipes-qt/qt6/qtwayland_git.bb
+++ b/recipes-qt/qt6/qtwayland_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-inherit qt6-cmake pkgconfig
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc
diff --git a/recipes-qt/qt6/qtwebengine.inc b/recipes-qt/qt6/qtwebengine.inc
index 06f23ee..23ac29b 100644
--- a/recipes-qt/qt6/qtwebengine.inc
+++ b/recipes-qt/qt6/qtwebengine.inc
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
"
-inherit qt6-cmake pkgconfig
+inherit qt6-cmake
include recipes-qt/qt6/qt6-git.inc
include recipes-qt/qt6/qt6.inc