aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-01-17 16:07:01 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-01-18 12:14:11 +0000
commit6364361d88cdcef3463a9b4f6d4b6c033906112a (patch)
tree1afc88dcb13e6bb904b2e1963af03c78af127aa7
parent5936d6e7a6ec37e9414d431ae0adc8150a28ba7f (diff)
sdk: don't filter nativesdk packages with DISTRO_FEATURES
The nativesdk builds have different set of DISTRO_FEATURES, which by default don't include wayland, even if it's used for target builds. Instead of filtering wayland packages based on the DISTRO_FEATUREs, always include them. The nativesdk packages builds correctly, even if wayland is not supported for the target. Fixes: QTBUG-99787 Change-Id: I9e00b5e4eacc340a985d0617911c02144ec3e6ed Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit a03cfa981d9f026f748d7802e924fc5d0c55edbe) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb
index 1e17ca3..3b31381 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb
@@ -33,7 +33,8 @@ RDEPENDS:${PN} += " \
nativesdk-qtshadertools-tools \
nativesdk-qttools-dev \
nativesdk-qttools-tools \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'nativesdk-qtwayland-dev nativesdk-qtwayland-tools', '', d)} \
+ nativesdk-qtwayland-dev \
+ nativesdk-qtwayland-tools \
"
RDEPENDS:${PN}:remove:mingw32 = " \