aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-12-27 16:11:57 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2021-12-31 15:43:42 +0200
commit850937df489adbc499c474927ade192be2fc98b1 (patch)
treeba32eeeb9cc4cfb3a751d85d760610fa5d230b61
parent0a797d9888a530c981fd48391e91f09f6bf0c784 (diff)
qtwebengine: update to 94-based chromium
QtWebEngine based on 94 chromium can be build with python3. Remove all references to python2 and its meta layer. Latest oe-core has version of ICU, freetype, harfbuzz and ffmpeg that are not compatible with Chromium. Disable those PACKAGECONFIGs by default. Change-Id: Ie2e38db14df0f51aaa87ecde7e0487b31be0bddd Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit 57b22c6ea036297ce0db45823b1971ef9398f576) Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
-rw-r--r--README.md1
-rw-r--r--coin/module_config.yaml2
-rw-r--r--coin/test-configs.inc2
-rw-r--r--recipes-qt/qt6/gn-native_git.bb1
-rw-r--r--recipes-qt/qt6/qt6-git.inc4
-rw-r--r--recipes-qt/qt6/qtpdf_git.bb1
-rw-r--r--recipes-qt/qt6/qtwebengine.inc14
-rw-r--r--recipes-qt/qt6/qtwebengine_git.bb8
8 files changed, 14 insertions, 19 deletions
diff --git a/README.md b/README.md
index 2e90393..54bfd7f 100644
--- a/README.md
+++ b/README.md
@@ -8,7 +8,6 @@ URI: https://git.openembedded.org/openembedded-core/
and optionally:
URI: https://git.openembedded.org/meta-openembedded/
-URI: https://git.openembedded.org/meta-python2
Yocto version support
---------------------
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
index ed31359..3e2039a 100644
--- a/coin/module_config.yaml
+++ b/coin/module_config.yaml
@@ -115,7 +115,6 @@ instructions:
git clone git://git.yoctoproject.org/poky --reference /mnt/yocto-cache/mirror/poky.git -b ${YOCTO_BRANCH}
git clone git://git.openembedded.org/meta-openembedded --reference /mnt/yocto-cache/mirror/meta-openembedded.git -b ${YOCTO_BRANCH}
git clone git://git.yoctoproject.org/meta-mingw --reference /mnt/yocto-cache/mirror/meta-mingw.git -b ${YOCTO_BRANCH}
- git clone git://git.openembedded.org/meta-python2 --reference /mnt/yocto-cache/mirror/meta-python2.git -b ${YOCTO_BRANCH}
source ./poky/oe-init-build-env
export BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE SSTATE_DIR DL_DIR"
@@ -128,7 +127,6 @@ instructions:
bitbake-layers add-layer ../meta-openembedded/meta-python
bitbake-layers add-layer ../meta-openembedded/meta-multimedia
bitbake-layers add-layer ../meta-mingw
- bitbake-layers add-layer ../meta-python2
bitbake-layers add-layer ${SOURCE_DIR}
if [ -n "${DISABLE_X11}" ] ; then
diff --git a/coin/test-configs.inc b/coin/test-configs.inc
index dca0f10..7903c1f 100644
--- a/coin/test-configs.inc
+++ b/coin/test-configs.inc
@@ -42,7 +42,7 @@ ARM_INSTRUCTION_SET = "${PREFERRED_ARM_INSTRUCTION_SET}"
# enable webengine with commercial/proprietary features
DISTRO_FEATURES:append = " webengine"
LICENSE_FLAGS_WHITELIST = "commercial"
-PACKAGECONFIG:append:pn-qtwebengine = " proprietary-codecs ffmpeg"
+PACKAGECONFIG:append:pn-qtwebengine = " proprietary-codecs"
PACKAGECONFIG:append:pn-qtbase = "\
tslib kms gbm zstd libproxy gssapi vulkan mtdev cups \
diff --git a/recipes-qt/qt6/gn-native_git.bb b/recipes-qt/qt6/gn-native_git.bb
index 8612fd2..6bcea89 100644
--- a/recipes-qt/qt6/gn-native_git.bb
+++ b/recipes-qt/qt6/gn-native_git.bb
@@ -3,6 +3,7 @@ require recipes-qt/qt6/qtwebengine.inc
inherit native
OECMAKE_SOURCEPATH = "${S}/src/gn"
+OECMAKE_TARGET_COMPILE = "gn"
cmake_do_install() {
eval DESTDIR='${D}' ${CMAKE_VERBOSE} cmake --install '${B}'
diff --git a/recipes-qt/qt6/qt6-git.inc b/recipes-qt/qt6/qt6-git.inc
index 8dc63c7..1307433 100644
--- a/recipes-qt/qt6/qt6-git.inc
+++ b/recipes-qt/qt6/qt6-git.inc
@@ -53,7 +53,7 @@ SRCREV_qttranslations = "31b28eae3861e25fdcdee0589fcf4ac1d7ab6e11"
SRCREV_qtvirtualkeyboard = "ed58cca73795c4a5baaa89f37462a299ebbfebf4"
SRCREV_qtwayland = "34a8147f22ecba79f35616386da47e446bd1eed7"
SRCREV_qtwebchannel = "f2f4e5235d07250531878592e8207982ec7910c1"
-SRCREV_qtwebengine = "da019632bfc0227e2d0d0cc676a80a352fc27a62"
-SRCREV_qtwebengine-chromium = "39aa0ea99a30c9c15fb3640fe9a2638982548c0b"
+SRCREV_qtwebengine = "99e34e9c99453b4990c82468260f431dede4e256"
+SRCREV_qtwebengine-chromium = "735b1a398df409a98e84ed0eb1afb0bafdd9dff9"
SRCREV_qtwebsockets = "cb7abc7ac0f19e0076a3927b0dd880606c6f92f6"
SRCREV_qtwebview = "be1c35d8198cfd0d9b9e0cfac2fe3f2dc963a5a4"
diff --git a/recipes-qt/qt6/qtpdf_git.bb b/recipes-qt/qt6/qtpdf_git.bb
index 4d8ca7e..f0f66ba 100644
--- a/recipes-qt/qt6/qtpdf_git.bb
+++ b/recipes-qt/qt6/qtpdf_git.bb
@@ -9,6 +9,7 @@ DEPENDS += " \
qtbase qtdeclarative qtdeclarative-native \
gn-native \
libxkbcommon \
+ python3-html5lib-native \
"
EXTRA_OECMAKE += "\
diff --git a/recipes-qt/qt6/qtwebengine.inc b/recipes-qt/qt6/qtwebengine.inc
index 06f23ee..ce1e807 100644
--- a/recipes-qt/qt6/qtwebengine.inc
+++ b/recipes-qt/qt6/qtwebengine.inc
@@ -1,8 +1,8 @@
-LICENSE = "BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( LGPL-3.0 | The-Qt-Company-Commercial )"
+LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://src/3rdparty/chromium/LICENSE;md5=0fca02217a5d49a14dfe2d11837bb34d \
+ file://LICENSE.FDL;md5=f70ee9a6c44ae8917586fea34dff0ab5 \
file://LICENSE.LGPL3;md5=8211fde12cc8a4e2477602f5953f5b71 \
- file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
@@ -15,20 +15,14 @@ include recipes-qt/qt6/qt6.inc
inherit gettext
inherit perlnative
-
-inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)}
-
-python() {
- if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
- raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
-}
+inherit python3native
# we don't want gettext.bbclass to append --enable-nls
def gettext_oeconf(d):
return ""
QT_MODULE = "qtwebengine"
-QT_MODULE_BRANCH_CHROMIUM = "90-based"
+QT_MODULE_BRANCH_CHROMIUM = "94-based"
FILESEXTRAPATHS:prepend := "${THISDIR}/qtwebengine:"
diff --git a/recipes-qt/qt6/qtwebengine_git.bb b/recipes-qt/qt6/qtwebengine_git.bb
index 2f09bac..23934f9 100644
--- a/recipes-qt/qt6/qtwebengine_git.bb
+++ b/recipes-qt/qt6/qtwebengine_git.bb
@@ -10,6 +10,7 @@ DEPENDS += " \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcomposite libxcursor libxi libxrandr libxtst libxkbfile', '', d)} \
qtbase qtdeclarative qtdeclarative-native \
gn-native \
+ python3-html5lib-native \
"
EXTRA_OECMAKE += "\
@@ -25,10 +26,7 @@ SECURITY_STRINGFORMAT = ""
PACKAGECONFIG ??= "\
${@bb.utils.filter('DISTRO_FEATURES', 'alsa pulseaudio', d)} \
- freetype \
glib \
- harfbuzz \
- icu \
libevent \
libjpeg \
libpci \
@@ -82,3 +80,7 @@ FILES:${PN} += "\
${QT6_INSTALL_TRANSLATIONSDIR} \
${QT6_INSTALL_DATADIR}/resources \
"
+
+# QA Issue: qtwebengine: ELF binary /usr/lib/libQt6WebEngineCore.so.6.3.0 has relocations in .text [textrel]
+# when proprietary-codecs is enabled
+INSANE_SKIP:${PN} += "textrel"