aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-02-09 18:00:21 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2022-02-10 10:43:54 +0000
commit85e55e56299911a30e8562407ef81f8f06e31f04 (patch)
treedde263dc1ae041247994c6fde6036a8ab622ca2a
parent2394565194a0d066b0bb304aec92164db285d17b (diff)
Revert "qtbase: fix mingw nativesdk build"
This reverts commit 68bd9cee63eaf612c8b650c8b95697e54ac3851b. Proper fix has been merged to qtbase. Change-Id: I394bc594d2b4d9b90b98f530d65703b4352afa29 Pick-to: dev Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io>
-rw-r--r--recipes-qt/qt6/qtbase/0001-rhi-d3d11-Try-uuidof-instead-of-IID_-to-help-old-Min.patch25
-rw-r--r--recipes-qt/qt6/qtbase_git.bb1
2 files changed, 0 insertions, 26 deletions
diff --git a/recipes-qt/qt6/qtbase/0001-rhi-d3d11-Try-uuidof-instead-of-IID_-to-help-old-Min.patch b/recipes-qt/qt6/qtbase/0001-rhi-d3d11-Try-uuidof-instead-of-IID_-to-help-old-Min.patch
deleted file mode 100644
index f21be51..0000000
--- a/recipes-qt/qt6/qtbase/0001-rhi-d3d11-Try-uuidof-instead-of-IID_-to-help-old-Min.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 91c7e146889f87f3a6a7bf1ab21694b4578cd2db Mon Sep 17 00:00:00 2001
-From: Laszlo Agocs <laszlo.agocs@qt.io>
-Date: Fri, 28 Jan 2022 11:29:16 +0100
-Subject: [PATCH] rhi: d3d11: Try uuidof instead of IID_* to help old MinGW
-
-Fixes: QTBUG-100294
-Pick-to: 6.3
-Change-Id: Iee90355ecd48a753f9a7ec53e7f5758e3d12eddf
----
- src/gui/rhi/qrhid3d11.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/gui/rhi/qrhid3d11.cpp b/src/gui/rhi/qrhid3d11.cpp
-index 54c8b4f477..973dfd2738 100644
---- a/src/gui/rhi/qrhid3d11.cpp
-+++ b/src/gui/rhi/qrhid3d11.cpp
-@@ -214,7 +214,7 @@ bool QRhiD3D11::create(QRhi::Flags flags)
- // sufficient to get non-blocking behavior, try using ALLOW_TEARING
- // when available.
- IDXGIFactory5 *factory5 = nullptr;
-- if (SUCCEEDED(dxgiFactory->QueryInterface(IID_IDXGIFactory5, reinterpret_cast<void **>(&factory5)))) {
-+ if (SUCCEEDED(dxgiFactory->QueryInterface(__uuidof(IDXGIFactory5), reinterpret_cast<void **>(&factory5)))) {
- BOOL allowTearing = false;
- if (SUCCEEDED(factory5->CheckFeatureSupport(DXGI_FEATURE_PRESENT_ALLOW_TEARING, &allowTearing, sizeof(allowTearing))))
- supportsAllowTearing = allowTearing;
diff --git a/recipes-qt/qt6/qtbase_git.bb b/recipes-qt/qt6/qtbase_git.bb
index 14b9c66..2acc80f 100644
--- a/recipes-qt/qt6/qtbase_git.bb
+++ b/recipes-qt/qt6/qtbase_git.bb
@@ -18,7 +18,6 @@ SRC_URI += "\
file://0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \
file://0003-tests-disable-failing-tests.patch \
file://0004-Do-not-use-QT_TOOLCHAIN_RELOCATABLE-paths-in-qt.tool.patch \
- file://0001-rhi-d3d11-Try-uuidof-instead-of-IID_-to-help-old-Min.patch \
"
DEPENDS += "\