aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-11-11 13:30:29 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2021-11-15 10:16:19 +0200
commitf7fd11bfce1ddcac5275ffa7cb43d583d1f321f7 (patch)
tree9ecc301aca36282e4c1ee36689e9f408e6180537
parent152d0e6e45bac828be7538df24ecc20ab3a4432c (diff)
qtspeech: remove recipe
QtSpeech is not officially supported on Qt6. It has been compiling until now, so it has been kept here, but since it now fails with Qt 6.3, remove the recipe. Change-Id: I2b0cce68b8bec82e0a5a434d0b3634ffb84eb6d8 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--coin/test-configs.inc1
-rw-r--r--recipes-qt/packagegroups/packagegroup-qt6-addons.bb1
-rw-r--r--recipes-qt/qt6/qt6-git.inc1
-rw-r--r--recipes-qt/qt6/qtspeech_git.bb15
4 files changed, 0 insertions, 18 deletions
diff --git a/coin/test-configs.inc b/coin/test-configs.inc
index 3725ce3..dca0f10 100644
--- a/coin/test-configs.inc
+++ b/coin/test-configs.inc
@@ -78,7 +78,6 @@ PACKAGECONFIG:append:pn-qtsensors = " examples"
PACKAGECONFIG:append:pn-qtserialbus = " examples"
PACKAGECONFIG:append:pn-qtserialport = " examples"
PACKAGECONFIG:append:pn-qtshadertools = " examples"
-PACKAGECONFIG:append:pn-qtspeech = " examples"
PACKAGECONFIG:append:pn-qtsvg = " examples"
PACKAGECONFIG:append:pn-qttools = " examples"
PACKAGECONFIG:append:pn-qttranslations = " examples"
diff --git a/recipes-qt/packagegroups/packagegroup-qt6-addons.bb b/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
index 270ff46..ef0f03c 100644
--- a/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
@@ -35,7 +35,6 @@ RDEPENDS:${PN} += " \
qtserialbus \
qtserialport \
qtshadertools \
- qtspeech \
qtsvg \
qttranslations \
qtvirtualkeyboard \
diff --git a/recipes-qt/qt6/qt6-git.inc b/recipes-qt/qt6/qt6-git.inc
index 4a9042c..8de09ed 100644
--- a/recipes-qt/qt6/qt6-git.inc
+++ b/recipes-qt/qt6/qt6-git.inc
@@ -45,7 +45,6 @@ SRCREV_qtsensors = "8a547dcb37d5d01a5f1c2e0e588f4488c5247de7"
SRCREV_qtserialbus = "ac6448c6da9b6ddb20ba5ccd30a371a24980e39c"
SRCREV_qtserialport = "9c1407b8506dbecf510cf15fbcd11631803d9952"
SRCREV_qtshadertools = "28460df15c4f16fc4e8bbdb37bd436774185019a"
-SRCREV_qtspeech = "e823c481693e4bfac733b44737ef02be8360b713"
SRCREV_qtsvg = "286c1f2f0a1d220a2665612eacabcc3cce861871"
SRCREV_qttools = "9ea05f1273565217831e0160bb8d5feff28c605a"
SRCREV_qttools-qlitehtml = "4931b7aa30f256c20573d283561aa432fecf8f38"
diff --git a/recipes-qt/qt6/qtspeech_git.bb b/recipes-qt/qt6/qtspeech_git.bb
deleted file mode 100644
index 4f88d57..0000000
--- a/recipes-qt/qt6/qtspeech_git.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-LICENSE = "GFDL-1.3 & (LGPL-3.0 | GPL-2.0+) | The-Qt-Company-Commercial"
-LIC_FILES_CHKSUM = " \
- file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
- file://LICENSE.GPLv2;md5=05832301944453ec79e40ba3c3cfceec \
- file://LICENSE.LGPLv3;md5=c4fe8c6de4eef597feec6e90ed62e962 \
-"
-
-inherit qt6-qmake
-
-
-include recipes-qt/qt6/qt6-git.inc
-include recipes-qt/qt6/qt6.inc
-
-DEPENDS += "qtbase"
-