aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-12-05 05:38:47 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2023-01-17 08:31:11 +0000
commit6b923c480324c4d167efbae99efdd26c41c6ca66 (patch)
tree9df32f5c35dbf29051c11bb78a69046bad9ed345
parentf4c32a89ebdb6957bc6ed48abe1f6c8b6e3f9c96 (diff)
Add recipe for QtInsightTracker
QtInsightTracker is a commercial-only module. Task-number: ANALYTICS-237 Task-number: QTBUG-108568 Change-Id: I30412dec8552898b76865402c2e2ccfcae8d1904 Reviewed-by: Ari Parkkila <ari.parkkila@qt.io> (cherry picked from commit 56710e87242e9f615aa942a0114c1291d4e68483)
-rw-r--r--coin/test-configs.inc1
-rw-r--r--recipes-qt/packagegroups/packagegroup-qt6-commercial-modules.bb1
-rw-r--r--recipes-qt/qt6/qt6-git.inc1
-rw-r--r--recipes-qt/qt6/qtinsighttracker_git.bb12
4 files changed, 15 insertions, 0 deletions
diff --git a/coin/test-configs.inc b/coin/test-configs.inc
index 59bb701..ff038e9 100644
--- a/coin/test-configs.inc
+++ b/coin/test-configs.inc
@@ -63,6 +63,7 @@ PACKAGECONFIG:append:pn-qtdeviceutilities = " examples"
PACKAGECONFIG:append:pn-qtgrpc = " examples"
PACKAGECONFIG:append:pn-qthttpserver = " examples"
PACKAGECONFIG:append:pn-qtimageformats = " examples"
+PACKAGECONFIG:append:pn-qtinsighttracker = " examples"
PACKAGECONFIG:append:pn-qtinterfaceframework = " examples"
PACKAGECONFIG:append:pn-qtlanguageserver = " examples"
PACKAGECONFIG:append:pn-qtlocation = " examples"
diff --git a/recipes-qt/packagegroups/packagegroup-qt6-commercial-modules.bb b/recipes-qt/packagegroups/packagegroup-qt6-commercial-modules.bb
index 9284e36..8a3db72 100644
--- a/recipes-qt/packagegroups/packagegroup-qt6-commercial-modules.bb
+++ b/recipes-qt/packagegroups/packagegroup-qt6-commercial-modules.bb
@@ -9,5 +9,6 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
RDEPENDS:${PN} += " \
qmlcompilerplus \
+ qtinsighttracker \
qtvncserver \
"
diff --git a/recipes-qt/qt6/qt6-git.inc b/recipes-qt/qt6/qt6-git.inc
index bc68951..1dcf888 100644
--- a/recipes-qt/qt6/qt6-git.inc
+++ b/recipes-qt/qt6/qt6-git.inc
@@ -17,6 +17,7 @@ PV = "6.5.0"
SRCREV = "${SRCREV_${QT_MODULE}}"
SRCREV_tqtc-qmlcompilerplus = "b75fdc869b84c54b21ab0dfd16e0831759563cae"
+SRCREV_tqtc-qtinsighttracker = "4ef3088c1562b8bf46b2c594515be78c049a198e"
SRCREV_tqtc-qtvncserver = "8c455a64f6828ec23c5f923dbd48525c99e75df2"
SRCREV_qt3d = "8f7723ab0b35134cf97e8e30019f07789c23a54b"
SRCREV_qt3d-assimp = "5a38cd0a03015ceabbd5bc6efb0730dde1ef74e5"
diff --git a/recipes-qt/qt6/qtinsighttracker_git.bb b/recipes-qt/qt6/qtinsighttracker_git.bb
new file mode 100644
index 0000000..e440e30
--- /dev/null
+++ b/recipes-qt/qt6/qtinsighttracker_git.bb
@@ -0,0 +1,12 @@
+LICENSE = "The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = "file://LICENSES/LicenseRef-Qt-Commercial.txt;md5=40a1036f91cefc0e3fabad241fb5f187"
+
+inherit qt6-cmake
+
+include recipes-qt/qt6/qt6-git.inc
+include recipes-qt/qt6/qt6.inc
+include recipes-qt/qt6/qt6-commercial.inc
+
+DEPENDS += "qtbase qtdeclarative qtdeclarative-native"
+
+FILES:${PN} += "${QT6_INSTALL_DATADIR}/qtinsight"