aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlaf Mandel <o.mandel@menlosystems.com>2023-05-22 11:03:23 +0200
committerOlaf Mandel <o.mandel@menlosystems.com>2023-05-25 07:23:05 +0200
commit16c7da9d10a84e1766b5469f5d3d097638d8e877 (patch)
treed4202f91fe2a6d901a7dd8af41bd012731b4cdbb
parentcf976a7d837e2abbb1f4e03768ac7887881c297b (diff)
Remove hard dependency on meta-python
Set up the BBFILES_DYNAMIC variable to include meta-python and move all python recipes to the corresponding dynamic-layers directory. This prevents failures to parse recipes if meta-python is not available. Pick-to: 6.5 Fixes: QTBUG-113712 Change-Id: If26668e8d901c89be8527ff3951a00d739a89372 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--conf/layer.conf2
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-antlr4-runtime_4.9.2.bb (renamed from recipes-devtools/python/python3-antlr4-runtime_4.9.2.bb)0
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bbappend (renamed from recipes-devtools/python/python3-appdirs_1.4.4.bbappend)0
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-path_16.2.0.bb (renamed from recipes-devtools/python/python3-path_16.2.0.bb)0
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-pathtools3_0.2.1.bb (renamed from recipes-devtools/python/python3-pathtools3_0.2.1.bb)0
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-pytest-qt_4.0.2.bb (renamed from recipes-devtools/python/python3-pytest-qt_4.0.2.bb)0
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-qface_2.0.4.bb (renamed from recipes-devtools/python/python3-qface_2.0.4.bb)0
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/python/python3-watchdog_0.9.0.bb (renamed from recipes-devtools/python/python3-watchdog_0.9.0.bb)0
8 files changed, 2 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index af389be..2520c14 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -16,6 +16,8 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
# bbappends for optional layers
BBFILES_DYNAMIC += " \
+ meta-python:${LAYERDIR}/dynamic-layers/meta-python/*/*/*.bb \
+ meta-python:${LAYERDIR}/dynamic-layers/meta-python/*/*/*.bbappend \
"
BBFILE_COLLECTIONS += "qt6-layer"
diff --git a/recipes-devtools/python/python3-antlr4-runtime_4.9.2.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-antlr4-runtime_4.9.2.bb
index 9e6444e..9e6444e 100644
--- a/recipes-devtools/python/python3-antlr4-runtime_4.9.2.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-antlr4-runtime_4.9.2.bb
diff --git a/recipes-devtools/python/python3-appdirs_1.4.4.bbappend b/dynamic-layers/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bbappend
index 608377e..608377e 100644
--- a/recipes-devtools/python/python3-appdirs_1.4.4.bbappend
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-appdirs_1.4.4.bbappend
diff --git a/recipes-devtools/python/python3-path_16.2.0.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-path_16.2.0.bb
index 70e19f2..70e19f2 100644
--- a/recipes-devtools/python/python3-path_16.2.0.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-path_16.2.0.bb
diff --git a/recipes-devtools/python/python3-pathtools3_0.2.1.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-pathtools3_0.2.1.bb
index 998bbd3..998bbd3 100644
--- a/recipes-devtools/python/python3-pathtools3_0.2.1.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-pathtools3_0.2.1.bb
diff --git a/recipes-devtools/python/python3-pytest-qt_4.0.2.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-pytest-qt_4.0.2.bb
index ea06112..ea06112 100644
--- a/recipes-devtools/python/python3-pytest-qt_4.0.2.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-pytest-qt_4.0.2.bb
diff --git a/recipes-devtools/python/python3-qface_2.0.4.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-qface_2.0.4.bb
index 9da0575..9da0575 100644
--- a/recipes-devtools/python/python3-qface_2.0.4.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-qface_2.0.4.bb
diff --git a/recipes-devtools/python/python3-watchdog_0.9.0.bb b/dynamic-layers/meta-python/recipes-devtools/python/python3-watchdog_0.9.0.bb
index 4fac7f9..4fac7f9 100644
--- a/recipes-devtools/python/python3-watchdog_0.9.0.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/python/python3-watchdog_0.9.0.bb