aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-08-15 06:32:07 +0000
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-08-15 13:00:38 +0000
commit1aa9356372f851aa291493e4224242d0978fee21 (patch)
treebd33e3c0993adb79c01dd1e2aa1b3fbd18fef7da
parent0b55d8ec947e80a7781144013e2c62426b509624 (diff)
qtbase: remove initial host path from CMake filesv6.4.0-beta3
Amend 0b55d8ec947e80a7781144013e2c62426b509624 and remove the initial host paths from CMake files. They point to the temporary build paths and cause build breaks in declarative builds. Change-Id: I17d46b989f024e71ec617ff130c8ea7d7fc85641 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit 7d1d6a11af843b15f2cc803546e1fdfaf431ab20) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--recipes-qt/qt6/qtbase_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt6/qtbase_git.bb b/recipes-qt/qt6/qtbase_git.bb
index dfb7e9e..b4a80cb 100644
--- a/recipes-qt/qt6/qtbase_git.bb
+++ b/recipes-qt/qt6/qtbase_git.bb
@@ -152,6 +152,9 @@ do_install:append() {
sed -i ${D}${libdir}/cmake/Qt6BuildInternals/QtBuildInternalsExtra.cmake \
-e '/QT_SOURCE_TREE/,+2d'
+ sed -i ${D}${QT6_INSTALL_LIBDIR}/cmake/Qt6/Qt6Dependencies.cmake \
+ -e '/set(__qt_platform_initial_qt_host/d'
+
# remove mac and android specific scripts that depend on perl and bash
# to avoid file-rdeps QA Issue.
rm -f ${D}${QT6_INSTALL_LIBEXECDIR}/android_emulator_launcher.sh