aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-08-25 09:23:41 +0000
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-08-28 17:26:09 +0000
commit4548dc9d327906c81baeefd208f636d063ac1217 (patch)
tree2c45259320603ef82efddb06c210eb55cc126348
parent391dddbfd59ee53295715d9fbad20dea7f452df2 (diff)
qtbase: fix install if lcl_maybe_fortify is empty
lcl_maybe_fortify might be empty, which would make sed fail during do_install. Workaround this by adding space to the substitution pattern. Fixes: QTBUG-115588 Change-Id: Ic6c5a6c80011dfefc92e1b2d7aadc48cce82ed7a Reviewed-by: Ari Parkkila <ari.parkkila@qt.io> (cherry picked from commit deab0703da3cfd6e333a900a2e339b666fded79e) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--recipes-qt/qt6/qtbase_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt6/qtbase_git.bb b/recipes-qt/qt6/qtbase_git.bb
index 41410c6..1b78558 100644
--- a/recipes-qt/qt6/qtbase_git.bb
+++ b/recipes-qt/qt6/qtbase_git.bb
@@ -182,7 +182,7 @@ EOF
do_install:append:class-target() {
sed >> ${D}${QT6_INSTALL_MKSPECSDIR}/linux-oe-g++/qmake.conf <<EOF \
- -e 's:${lcl_maybe_fortify}::' \
+ -e 's: ${lcl_maybe_fortify}: :' \
-e 's:${DEBUG_PREFIX_MAP}::' \
-e 's:${RECIPE_SYSROOT}:$$[QT_SYSROOT]:' \
-e 's:${TARGET_PREFIX}:$$[QT_HOST_PREFIX]${bindir}/${TARGET_SYS}/${TARGET_PREFIX}:'