aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaeyoon Jung <jaeyoon.jung@lge.com>2023-08-29 15:55:35 +0900
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-08-30 14:38:00 +0000
commitcd1391211aa688de49660bb29a93bd2672fc29a7 (patch)
tree997f03a8597edf4f728cbe5ffe8ef4e2e9902ada
parent7229fabf90b6d23af342717cd3a28206e5eb1f0e (diff)
qtshadertools: Fix missing dependency to spirv-tools
qsb needs spirv-tools when -O flag is given, but it is not pulled in recipe-sysroot-native due to missing dependency. It causes qsb files are not created as output. Errors like below can be seen with a small tweak that makes qsb run with no -s flag. [1/218] cd /home/noelma/work/webos/build-webos/BUILD/work/x86_64-linux/qtdeclarative-native/6.7.0-r0/build/src/quick && /home/noelma/work/webos/build-webos/BUILD/work/x86_64-linux/qtdeclarative-native/6.7.0-r0/recipe-sysroot-native/usr/bin/qsb --glsl 100es,120,150 --hlsl 50 --msl 12 -b -O -o /home/noelma/work/webos/build-webos/BUILD/work/x86_64-linux/qtdeclarative-native/6.7.0-r0/build/src/quick/.qsb/scenegraph/shaders_ng/8bittextmask.frag.qsb /home/noelma/work/webos/build-webos/BUILD/work/x86_64-linux/qtdeclarative-native/6.7.0-r0/git/src/quick/scenegraph/shaders_ng/8bittextmask.frag spirv-opt -O /tmp/qsb-XOAphY/qsb_spv_temp -o /tmp/qsb-XOAphY/qsb_spv_temp_out Failed to run spirv-opt -O /tmp/qsb-XOAphY/qsb_spv_temp -o /tmp/qsb-XOAphY/qsb_spv_temp_out: Child process set up failed: execve: No such file or directory Change-Id: I49c88711be4ca09425fa71f8ce8eda88256370f6 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> (cherry picked from commit 7c2a20a1c581e9189622b004ded2a3a1107778b0) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--recipes-qt/qt6/qtshadertools_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-qt/qt6/qtshadertools_git.bb b/recipes-qt/qt6/qtshadertools_git.bb
index 7b4e93c..b0efd9e 100644
--- a/recipes-qt/qt6/qtshadertools_git.bb
+++ b/recipes-qt/qt6/qtshadertools_git.bb
@@ -10,6 +10,7 @@ include recipes-qt/qt6/qt6-lts.inc
include recipes-qt/qt6/qt6.inc
DEPENDS = "qtbase qtshadertools-native"
+DEPENDS:append:class-native = " spirv-tools-native"
RDEPENDS:${PN}-tools = "spirv-tools"
RDEPENDS:${PN}-tools:remove:mingw32 = "spirv-tools"