aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-04-07 14:58:50 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2022-04-27 07:04:37 +0000
commit3dfa092ad6c99cc8396e2e18cee29067d04ac15a (patch)
tree849d5ad0a6d55a8e5ddb9c071ad222e196258702
parent5f29322cb13fee6bdc8863734e4d5d2e7f97478a (diff)
qtwebengine: skip host build
QtWebEngine normally does a host build before the actual cross-compilation build. We can skip that since during the cross-compilation, the target binaries are run using QEMU instead of ones from the host build. Fixes: QTBUG-102378 Change-Id: I586a68641b48678933ed91a742235c6b22f1d109 Reviewed-by: Pasi Petäjäjärvi <pasi.petajajarvi@qt.io> (cherry picked from commit 73927c6db31db90dc9c5d461fccb8aeb66ead1a0) Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt6/qtwebengine/0001-CMake-use-generated-yocto-toolchains.patch29
1 files changed, 22 insertions, 7 deletions
diff --git a/recipes-qt/qt6/qtwebengine/0001-CMake-use-generated-yocto-toolchains.patch b/recipes-qt/qt6/qtwebengine/0001-CMake-use-generated-yocto-toolchains.patch
index e3c4bd5..225a8fe 100644
--- a/recipes-qt/qt6/qtwebengine/0001-CMake-use-generated-yocto-toolchains.patch
+++ b/recipes-qt/qt6/qtwebengine/0001-CMake-use-generated-yocto-toolchains.patch
@@ -1,23 +1,25 @@
-From 7c16e38b85e514991d57802136de498ac1201bca Mon Sep 17 00:00:00 2001
+From 271b265784767476101f64f51e87abdeeae18108 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Wed, 18 Aug 2021 15:09:41 +0300
Subject: [PATCH] CMake: use generated yocto toolchains
Bitbake knows how to generate working toolchains, use those instead of
ones done by webengine. No need to use separate host pkg-wrapper with
-these toolchain.
+these toolchain. No need to do separate host build, we'll use the
+target binaries where needed.
-Upstream-Status: Inappropriate [embedder specific]
+Upstream-Status: Inappropriate [embedded specific]
Change-Id: I217c9122144f25bb2d28717e7248c2a51b149127
---
cmake/Functions.cmake | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
+ src/CMakeLists.txt | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/cmake/Functions.cmake b/cmake/Functions.cmake
-index 37fd593a..2654cdc3 100644
+index 08967d6db..cebeae8eb 100644
--- a/cmake/Functions.cmake
+++ b/cmake/Functions.cmake
-@@ -642,7 +642,7 @@ endfunction()
+@@ -750,7 +750,7 @@ endfunction()
macro(create_pkg_config_host_wrapper buildDir)
find_package(PkgConfigHost)
@@ -26,7 +28,7 @@ index 37fd593a..2654cdc3 100644
create_pkg_config_wrapper("${buildDir}/pkg-config-host_wrapper.sh" "${PKG_CONFIG_HOST_EXECUTABLE}")
set(PKG_CONFIG_HOST_EXECUTABLE "${buildDir}/pkg-config-host_wrapper.sh")
endif()
-@@ -855,9 +855,9 @@ endmacro()
+@@ -972,9 +972,9 @@ endmacro()
macro(append_toolchain_setup)
if(LINUX)
list(APPEND gnArgArg
@@ -39,3 +41,16 @@ index 37fd593a..2654cdc3 100644
)
get_gn_arch(cpu ${TEST_architecture_arch})
if(CMAKE_CROSSCOMPILING)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 31123d06c..c6141988b 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -151,7 +151,7 @@ endif()
+ # HOST PROJECT
+ ##
+
+-if(CMAKE_CROSSCOMPILING AND NOT IOS)
++if(FALSE)
+
+ if(NOT Gn_FOUND)
+ message(FATAL_ERROR "\nHost gn not found - cross compilation not possible")