aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-11-26 11:13:19 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2020-11-27 07:26:52 +0200
commit59d929603c47cac8b0d55feb0516148c2f36b663 (patch)
treee4e8e09a8673c18be46a40ee849ff4feae4d3fb0
parentb1adc3fa3a86a1aeca27727fa8caef8b9c69637e (diff)
Update example and test PACKAGECONFIG
The CMake options were renamed. Change-Id: Ib4bc6019b75b422d22306a8d5129512171008705 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt6/qt6.inc4
-rw-r--r--recipes-qt/qt6/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt6/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt6/qtvirtualkeyboard_git.bb2
4 files changed, 5 insertions, 5 deletions
diff --git a/recipes-qt/qt6/qt6.inc b/recipes-qt/qt6/qt6.inc
index cf51a6b..fe473ce 100644
--- a/recipes-qt/qt6/qt6.inc
+++ b/recipes-qt/qt6/qt6.inc
@@ -1,7 +1,7 @@
inherit srcrev-update
-PACKAGECONFIG[examples] = "-DBUILD_EXAMPLES=ON,-DBUILD_EXAMPLES=OFF,"
-PACKAGECONFIG[tests] = "-DBUILD_TESTING=ON,-DBUILD_TESTING=OFF,"
+PACKAGECONFIG[examples] = "-DQT_BUILD_EXAMPLES=ON,-DQT_BUILD_EXAMPLES=OFF,"
+PACKAGECONFIG[tests] = "-DQT_BUILD_TESTS=ON,-DQT_BUILD_TESTS=OFF,"
# If Qt6 (qtbase) is machine specific, then everything will be,
# because the (initial) qtbase configuration becomes part of Qt5/qmake
diff --git a/recipes-qt/qt6/qtmqtt_git.bb b/recipes-qt/qt6/qtmqtt_git.bb
index 31dbc0b..b2449e7 100644
--- a/recipes-qt/qt6/qtmqtt_git.bb
+++ b/recipes-qt/qt6/qtmqtt_git.bb
@@ -13,6 +13,6 @@ include recipes-qt/qt6/qt6.inc
DEPENDS += "qtbase"
-PACKAGECONFIG[examples] = "-DBUILD_EXAMPLES=ON,-DBUILD_EXAMPLES=OFF,qtdeclarative qtwebsockets"
+PACKAGECONFIG[examples] = "-DQT_BUILD_EXAMPLES=ON,-DQT_BUILD_EXAMPLES=OFF,qtdeclarative qtwebsockets"
SRCREV = "841b2de545466c8f9306a599d7b1b9647c2711d0"
diff --git a/recipes-qt/qt6/qtopcua_git.bb b/recipes-qt/qt6/qtopcua_git.bb
index a281c95..ba545fc 100644
--- a/recipes-qt/qt6/qtopcua_git.bb
+++ b/recipes-qt/qt6/qtopcua_git.bb
@@ -14,7 +14,7 @@ include recipes-qt/qt6/qt6.inc
PACKAGECONFIG ?= "qtdeclarative"
PACKAGECONFIG[qtdeclarative] = ",,qtdeclarative"
-PACKAGECONFIG[examples] = "-DBUILD_EXAMPLES=ON,-DBUILD_EXAMPLES=OFF,,qtquickcontrols2"
+PACKAGECONFIG[examples] = "-DQT_BUILD_EXAMPLES=ON,-DQT_BUILD_EXAMPLES=OFF,,qtquickcontrols2"
# src/3rdparty/open62541.pri adds -Wno-format, causing following error
# because -Wformat-security cannot be used together with -Wno-format
diff --git a/recipes-qt/qt6/qtvirtualkeyboard_git.bb b/recipes-qt/qt6/qtvirtualkeyboard_git.bb
index 83d9498..14e6f67 100644
--- a/recipes-qt/qt6/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt6/qtvirtualkeyboard_git.bb
@@ -64,7 +64,7 @@ VKB_LANGUAGES ?= "\
PACKAGECONFIG ?= "${VKB_LANGUAGES} ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'desktop', '', d)}"
-PACKAGECONFIG[examples] = "-DBUILD_EXAMPLES=ON,-DBUILD_EXAMPLES=OFF,qtquickcontrols2"
+PACKAGECONFIG[examples] = "-DQT_BUILD_EXAMPLES=ON,-DQT_BUILD_EXAMPLES=OFF,qtquickcontrols2"
PACKAGECONFIG[desktop] = "-DFEATURE_vkb_desktop=ON,-DFEATURE_vkb_desktop=OFF"
PACKAGECONFIG[arrow-keynavigation] = "-DFEATURE_vkb_arrow_keynavigation=ON,-DFEATURE_vkb_arrow_keynavigation=OFF"
PACKAGECONFIG[hunspell] = "-DFEATURE_hunspell=ON,-DFEATURE_hunspell=OFF,hunspell"