aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPasi Petäjäjärvi <pasi.petajajarvi@qt.io>2021-08-20 12:40:21 +0300
committerPasi Petäjäjärvi <pasi.petajajarvi@qt.io>2021-12-29 12:35:24 +0200
commit2a5b08abdbd0333dc245a15e929fbd5b513d59e4 (patch)
treec589e41c2d225253f43ad131ef86fc98bbf4b67d
parent7b9b54e5d32ff530345ad5c099a4c92caec2ae78 (diff)
QtApplicationManager: Add support
Adds Qt Application Manager module Task-number: QTBUG-94105 Change-Id: I536b088c69b7ace484fbeef8e8a0e8136a1abacc Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> (cherry picked from commit 082551ef785d91a3cd06b45848a4f9f0eea30317)
-rw-r--r--recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb2
-rw-r--r--recipes-qt/packagegroups/packagegroup-qt6-addons.bb1
-rw-r--r--recipes-qt/qt6/qt6-git.inc1
-rw-r--r--recipes-qt/qt6/qtapplicationmanager_git.bb21
4 files changed, 25 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb b/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb
index cf9c0f4..1e17ca3 100644
--- a/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb
+++ b/recipes-qt/packagegroups/nativesdk-packagegroup-qt6-toolchain-host.bb
@@ -14,6 +14,8 @@ RDEPENDS:${PN} += " \
nativesdk-ninja \
nativesdk-perl-modules \
${@bb.utils.contains('ENABLE_QMLCOMPILER', '1', 'nativesdk-qmlcompilerplus-dev nativesdk-qmlcompilerplus-tools', '', d)} \
+ nativesdk-qtapplicationmanager-dev \
+ nativesdk-qtapplicationmanager-tools \
nativesdk-qtbase-dev \
nativesdk-qtbase-tools \
nativesdk-qtdeclarative-dev \
diff --git a/recipes-qt/packagegroups/packagegroup-qt6-addons.bb b/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
index 555f4ac..6a551f8 100644
--- a/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
@@ -11,6 +11,7 @@ RDEPENDS:${PN} += " \
${@bb.utils.contains('ENABLE_QMLCOMPILER', '1', 'qmlcompilerplus', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'qt3d', '', d)} \
qt5compat \
+ qtapplicationmanager \
qtcharts \
qtcoap \
qtconnectivity \
diff --git a/recipes-qt/qt6/qt6-git.inc b/recipes-qt/qt6/qt6-git.inc
index 96296fb..f40666b 100644
--- a/recipes-qt/qt6/qt6-git.inc
+++ b/recipes-qt/qt6/qt6-git.inc
@@ -20,6 +20,7 @@ SRCREV_qt3d = "54011d69f17eae299f81205a12c5b3dd280bec15"
SRCREV_qt3d-assimp = "5a38cd0a03015ceabbd5bc6efb0730dde1ef74e5"
SRCREV_qt5compat = "8309a3eb2a884c4d4e6691ef4d5c672d9518926c"
SRCREV_qtbase = "48a1fc1cba99cde6ac6cb3fe2f827b00f989bf4b"
+SRCREV_qtapplicationmanager = "a21bec7d87a2f0e84053707f6e7d06cecc73522e"
SRCREV_qtcharts = "5209a2a446c3d9de8d5d50902203421bcba0489b"
SRCREV_qtcoap = "93e9a24d325278eade0ea9e5e4d575cd727d6985"
SRCREV_qtconnectivity = "da848df253adbe5f445d542e72605e788bbdf06e"
diff --git a/recipes-qt/qt6/qtapplicationmanager_git.bb b/recipes-qt/qt6/qtapplicationmanager_git.bb
new file mode 100644
index 0000000..9bde067
--- /dev/null
+++ b/recipes-qt/qt6/qtapplicationmanager_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Qt component for application lifecycle management"
+LICENSE = "(GFDL-1.3 & The-Qt-Company-GPL-Exception-1.0 & (LGPL-3.0 | GPL-2.0+)) | The-Qt-Company-Commercial"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504"
+
+inherit qt6-cmake
+
+include recipes-qt/qt6/qt6-git.inc
+include recipes-qt/qt6/qt6.inc
+
+DEPENDS += "qtbase qtdeclarative libyaml libarchive qtapplicationmanager-native"
+RDEPENDS:${PN}:class-target = "libcrypto ${PN}-tools"
+
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'multi-process', '', d)}"
+
+PACKAGECONFIG[tools-only] = "-DFEATURE_am_tools_only=ON, -DFEATURE_am_tools_only=OFF"
+PACKAGECONFIG[multi-process] = "-DFEATURE_am_multi_process=ON, -DFEATURE_am_multi_process=OFF, qtwayland qtwayland-native"
+
+PACKAGECONFIG:class-native ??= "tools-only"
+PACKAGECONFIG:class-nativesdk ??= "${PACKAGECONFIG:class-native}"
+
+BBCLASSEXTEND = "nativesdk native"