aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-11-22 14:34:38 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2022-11-24 12:20:31 +0000
commit6db104bd2912decb7cdc5f38be4ebc53c0413708 (patch)
treedbda85a1cf494cc93469a2721b84cc5775955528
parentfb725ebed9021002ee2f8a76d6f795cfea8a32db (diff)
Add recipe for QtgRPC
QtgRPC module is Providing protobuf and gRPC support for Qt. Cannot include nativesdk-qtgrpc in the sdk yet, since it requires fix to protobuf recipe in meta-openembedded. Task-number: QTBUG-107921 Change-Id: Ie5ef1b493b1b5550c7b7f308a638c9855342dfa5 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--coin/test-configs.inc1
-rw-r--r--recipes-qt/packagegroups/packagegroup-qt6-addons.bb1
-rw-r--r--recipes-qt/qt6/qt6-git.inc1
-rw-r--r--recipes-qt/qt6/qtgrpc_git.bb18
4 files changed, 21 insertions, 0 deletions
diff --git a/coin/test-configs.inc b/coin/test-configs.inc
index 26802f3..99c0933 100644
--- a/coin/test-configs.inc
+++ b/coin/test-configs.inc
@@ -62,6 +62,7 @@ PACKAGECONFIG:append:pn-qtconnectivity = " examples"
PACKAGECONFIG:append:pn-qtdatavis3d = " examples"
PACKAGECONFIG:append:pn-qtdeclarative = " examples"
PACKAGECONFIG:append:pn-qtdeviceutilities = " examples"
+PACKAGECONFIG:append:pn-qtgrpc = " examples"
PACKAGECONFIG:append:pn-qthttpserver = " examples"
PACKAGECONFIG:append:pn-qtimageformats = " examples"
PACKAGECONFIG:append:pn-qtinterfaceframework = " examples"
diff --git a/recipes-qt/packagegroups/packagegroup-qt6-addons.bb b/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
index 2b82223..3695ff4 100644
--- a/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
@@ -16,6 +16,7 @@ RDEPENDS:${PN} += " \
qtconnectivity \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'qtdatavis3d', '', d)} \
qtdeviceutilities \
+ ${@bb.utils.contains('BBFILE_COLLECTIONS', 'openembedded-layer', 'qtgrpc', '', d)} \
qthttpserver \
qtimageformats \
${@bb.utils.contains('BBFILE_COLLECTIONS', 'meta-python', 'qtinterfaceframework', '', d)} \
diff --git a/recipes-qt/qt6/qt6-git.inc b/recipes-qt/qt6/qt6-git.inc
index cf24d3d..84bf6a7 100644
--- a/recipes-qt/qt6/qt6-git.inc
+++ b/recipes-qt/qt6/qt6-git.inc
@@ -29,6 +29,7 @@ SRCREV_qtconnectivity = "9f7fae5537ddcbbe720f796f61f65401c98b5151"
SRCREV_qtdatavis3d = "1a623493fe5fa58c7b1888b6469e3af06a9c3aee"
SRCREV_qtdeclarative = "a85d9da10ff8e97772158f9a4fb0dc156cae0cb8"
SRCREV_qtdeviceutilities = "348be509e7fbb90b683d2fc42d226a26f2331ecb"
+SRCREV_qtgrpc = "72ecabc23e696f466c40bffe65158b85ec704678"
SRCREV_qthttpserver = "e147b436eaa5d834912ec2137b120a23523b24c7"
SRCREV_qtimageformats = "edfc13086c1af70a9bfaeaf026a5f557a9b58c9c"
SRCREV_qtinterfaceframework = "377516ebdf09bd62ce0f458dfc326062e3cc1fde"
diff --git a/recipes-qt/qt6/qtgrpc_git.bb b/recipes-qt/qt6/qtgrpc_git.bb
new file mode 100644
index 0000000..b6474cd
--- /dev/null
+++ b/recipes-qt/qt6/qtgrpc_git.bb
@@ -0,0 +1,18 @@
+LICENSE = "The-Qt-Company-Commercial | (LGPL-3.0-only | GPL-2.0-only) & (LGPL-3.0-only | GPL-2.0-only | GPL-3.0-only) & GFDL-1.3-no-invariants-only & BSD-3-Clause"
+LIC_FILES_CHKSUM = " \
+ file://LICENSES/BSD-3-Clause.txt;md5=cb40fa7520502d8c7a3aea47cae1316c \
+ file://LICENSES/GFDL-1.3-no-invariants-only.txt;md5=a22d0be1ce2284b67950a4d1673dd1b0 \
+ file://LICENSES/GPL-2.0-only.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSES/GPL-3.0-only.txt;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LICENSES/LGPL-3.0-only.txt;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+ file://LICENSES/LicenseRef-Qt-Commercial.txt;md5=40a1036f91cefc0e3fabad241fb5f187 \
+"
+
+inherit qt6-cmake
+
+include recipes-qt/qt6/qt6-git.inc
+include recipes-qt/qt6/qt6.inc
+
+DEPENDS += "qtbase qtgrpc-native protobuf protobuf-native"
+
+BBCLASSEXTEND = "native nativesdk"