aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-08-10 05:22:10 +0000
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-10-20 07:19:52 +0000
commitaa5aa76ef1ce0f08e811a17eaad5d7b1d3c4f277 (patch)
tree3460190b4d0afeffcde4481963bb62de588f8aa9
parentf51473e3498875f84d7108459677d9bf8a244213 (diff)
qtwebengine: move to 102-based chromium
Latest chromium no longer supports x86 builds. Enabled spellchecker as build fails without it. Change-Id: I6f40d48c20a47edbbc958e2f9c25907d05feb5b1 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit c1441fcabcee46f1d3569d5d9b00e68546564dab) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--coin/module_config.yaml2
-rw-r--r--recipes-qt/qt6/chromium-gn.inc1
-rw-r--r--recipes-qt/qt6/qtwebengine.inc2
-rw-r--r--recipes-qt/qt6/qtwebengine_git.bb1
4 files changed, 3 insertions, 3 deletions
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
index 442172c..88e55ae 100644
--- a/coin/module_config.yaml
+++ b/coin/module_config.yaml
@@ -50,7 +50,7 @@ target2: &target2
variableValue: honister.xml
- type: EnvironmentVariable
variableName: TEST_CONFIGS
- variableValue: ci configs pre-inclusive wayland mingw
+ variableValue: ci configs pre-inclusive wayland mingw no-webengine
enable_if:
condition: property
property: target.arch
diff --git a/recipes-qt/qt6/chromium-gn.inc b/recipes-qt/qt6/chromium-gn.inc
index b7bba99..5d697ab 100644
--- a/recipes-qt/qt6/chromium-gn.inc
+++ b/recipes-qt/qt6/chromium-gn.inc
@@ -8,7 +8,6 @@ COMPATIBLE_MACHINE:aarch64 = "(.*)"
COMPATIBLE_MACHINE:armv6 = "(.*)"
COMPATIBLE_MACHINE:armv7a = "(.*)"
COMPATIBLE_MACHINE:armv7ve = "(.*)"
-COMPATIBLE_MACHINE:x86 = "(.*)"
COMPATIBLE_MACHINE:x86-64 = "(.*)"
# By default, passing is_official_build=true to GN causes its symbol_level
diff --git a/recipes-qt/qt6/qtwebengine.inc b/recipes-qt/qt6/qtwebengine.inc
index a511c76..c62bd3f 100644
--- a/recipes-qt/qt6/qtwebengine.inc
+++ b/recipes-qt/qt6/qtwebengine.inc
@@ -23,7 +23,7 @@ def gettext_oeconf(d):
return ""
QT_MODULE = "qtwebengine"
-QT_MODULE_BRANCH_CHROMIUM = "98-based"
+QT_MODULE_BRANCH_CHROMIUM = "102-based"
FILESEXTRAPATHS:prepend := "${THISDIR}/qtwebengine:"
diff --git a/recipes-qt/qt6/qtwebengine_git.bb b/recipes-qt/qt6/qtwebengine_git.bb
index 5801532..1972a91 100644
--- a/recipes-qt/qt6/qtwebengine_git.bb
+++ b/recipes-qt/qt6/qtwebengine_git.bb
@@ -38,6 +38,7 @@ PACKAGECONFIG ??= "\
webchannel \
printing-and-pdf \
pepper-plugins \
+ spellchecker \
"
PACKAGECONFIG_OPENEMBEDDED ?= "\
lcms2 \