aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-11-10 09:59:33 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2022-11-14 08:06:30 +0000
commitc48b6f8890e33a184a94a936b2f3e858460bfd73 (patch)
tree9ac22d969cee780d3b1249fd31de318c20c86049
parent2f6951d07b04b96274b4d6aad3e8340d2077293e (diff)
Use *-tools package only for tools
Some of the modules have executables that are necessary for the module to work properly. Don't put them into the *-tools package which is not installed by default. Task-number: QTBUG-99702 Change-Id: I7a9e8532862644574bd2bfb729e6efe466dac070 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/packagegroups/packagegroup-qt6-addons.bb3
-rw-r--r--recipes-qt/qt6/qtapplicationmanager_git.bb6
-rw-r--r--recipes-qt/qt6/qtconnectivity_git.bb1
-rw-r--r--recipes-qt/qt6/qtquick3dphysics_git.bb2
-rw-r--r--recipes-qt/qt6/qtwebengine_git.bb2
5 files changed, 11 insertions, 3 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-qt6-addons.bb b/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
index a1ff443..b4ce3db 100644
--- a/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-qt6-addons.bb
@@ -14,7 +14,6 @@ RDEPENDS:${PN} += " \
qtcharts \
qtcoap \
qtconnectivity \
- ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'qtconnectivity-tools', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'qtdatavis3d', '', d)} \
qtdeviceutilities \
qthttpserver \
@@ -47,10 +46,8 @@ RDEPENDS:${PN} += " \
ARCHITECTURE_LIMITED_MODULES = "\
qtquick3dphysics \
- qtquick3dphysics-tools \
${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtpdf', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebengine-tools', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'webengine', 'qtwebview', '', d)} \
"
RDEPENDS:${PN}:append:aarch64 ="${ARCHITECTURE_LIMITED_MODULES}"
diff --git a/recipes-qt/qt6/qtapplicationmanager_git.bb b/recipes-qt/qt6/qtapplicationmanager_git.bb
index 1bd5194..1c005c6 100644
--- a/recipes-qt/qt6/qtapplicationmanager_git.bb
+++ b/recipes-qt/qt6/qtapplicationmanager_git.bb
@@ -24,4 +24,10 @@ PACKAGECONFIG[multi-process] = "-DFEATURE_am_multi_process=ON, -DFEATURE_am_mult
PACKAGECONFIG:class-native ??= "tools-only"
PACKAGECONFIG:class-nativesdk ??= "${PACKAGECONFIG:class-native}"
+FILES:${PN}-tools = "\
+ ${QT6_INSTALL_BINDIR}/appman-packager* \
+ ${QT6_INSTALL_BINDIR}/appman-dumpqmltypes* \
+ ${QT6_INSTALL_BINDIR}/appman-qmltestrunner* \
+"
+
BBCLASSEXTEND = "nativesdk native"
diff --git a/recipes-qt/qt6/qtconnectivity_git.bb b/recipes-qt/qt6/qtconnectivity_git.bb
index 864b83d..e5c4851 100644
--- a/recipes-qt/qt6/qtconnectivity_git.bb
+++ b/recipes-qt/qt6/qtconnectivity_git.bb
@@ -22,3 +22,4 @@ DEPENDS += "qtbase qtdeclarative qtdeclarative-native"
PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
PACKAGECONFIG[bluez] = "-DFEATURE_bluez=ON,-DFEATURE_bluez=OFF,bluez5"
+FILES:${PN}-tools = ""
diff --git a/recipes-qt/qt6/qtquick3dphysics_git.bb b/recipes-qt/qt6/qtquick3dphysics_git.bb
index 54d5f72..c7a106e 100644
--- a/recipes-qt/qt6/qtquick3dphysics_git.bb
+++ b/recipes-qt/qt6/qtquick3dphysics_git.bb
@@ -20,3 +20,5 @@ COMPATIBLE_MACHINE:x86 = "(.*)"
COMPATIBLE_MACHINE:x86-64 = "(.*)"
DEPENDS = "qtbase qtquick3d qtquick3d-native qtdeclarative-native"
+
+FILES:${PN}-tools = ""
diff --git a/recipes-qt/qt6/qtwebengine_git.bb b/recipes-qt/qt6/qtwebengine_git.bb
index ce2d564..c5707c4 100644
--- a/recipes-qt/qt6/qtwebengine_git.bb
+++ b/recipes-qt/qt6/qtwebengine_git.bb
@@ -80,6 +80,8 @@ FILES:${PN} += "\
${QT6_INSTALL_DATADIR}/resources \
"
+FILES:${PN}-tools = ""
+
# QA Issue: qtwebengine: ELF binary /usr/lib/libQt6WebEngineCore.so.6.3.0 has relocations in .text [textrel]
# when proprietary-codecs is enabled
INSANE_SKIP:${PN} += "textrel"