aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorPasi Petäjäjärvi <pasi.petajajarvi@qt.io>2021-09-22 15:03:57 +0300
committerPasi Petäjäjärvi <pasi.petajajarvi@qt.io>2021-12-27 14:23:04 +0200
commit34e7839619b26491cd03e5e14bbb0903c81dfc9d (patch)
treee63ed153f94b2c373f92d6450dad05dc45d499cf /recipes-devtools
parent1022f279873aa32c7f3458830f990bc8a1c6b36e (diff)
QtIF: Use qface from 3rd party repo
With newer yocto old qface recipe using our internal repo suddenly preferred pypi own repository for qface. So use external version of qface instead and try to get that added to meta-python also. Fixes: QTBUG-96727 Change-Id: Ia6fae613f6d8ced531dad2bda4f1abc18cbf7eba Reviewed-by: Samuli Piippo <samuli.piippo@qt.io> (cherry picked from commit ce7a39b78be489cf8f65dbc5df2aaebeac96b89a)
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python3-qface_2.0.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-qface_2.0.4.bb b/recipes-devtools/python/python3-qface_2.0.4.bb
new file mode 100644
index 0000000..db1a3c8
--- /dev/null
+++ b/recipes-devtools/python/python3-qface_2.0.4.bb
@@ -0,0 +1,21 @@
+inherit pypi setuptools3
+
+DEPS += " python3-jinja2 \
+ python3-click \
+ python3-pyyaml \
+ python3-pytest \
+ python3-six \
+ python3-path \
+ python3-antrl4-runtime \
+ python3-watchdog \
+ python3-markupsafe \
+ python3-setuptools \
+ "
+DEPENDS += "${DEPS}"
+RDEPENDS:${PN} += "${DEPS}"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=eee61e10a40b0e3045ee5965bcd9a8b5"
+SRC_URI[sha256sum] = "42b0a0d37ed77cf1a9994f5ed77e3a6138468241df1700667a9ab0b848d6ad57"
+
+BBCLASSEXTEND = "nativesdk native"