summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..7c96b7c
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,26 @@
+cmake_minimum_required(VERSION 3.16)
+include(.cmake.conf)
+
+project(appcontroller LANGUAGES CXX)
+
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+set(CMAKE_AUTOMOC ON)
+
+find_package(Qt6 COMPONENTS Network)
+
+qt6_add_executable(appcontroller
+ main.cpp
+ process.cpp
+ portlist.cpp
+ perfprocesshandler.cpp
+)
+
+target_link_libraries(appcontroller PUBLIC
+ Qt::Network
+)
+
+install(TARGETS appcontroller
+ RUNTIME DESTINATION bin
+)