aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmldesigner/wizard/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qmldesigner/wizard/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmldesigner/wizard/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/auto/qml/qmldesigner/wizard/CMakeLists.txt b/tests/auto/qml/qmldesigner/wizard/CMakeLists.txt
index ca3a0ac7ec..de84a6e931 100644
--- a/tests/auto/qml/qmldesigner/wizard/CMakeLists.txt
+++ b/tests/auto/qml/qmldesigner/wizard/CMakeLists.txt
@@ -5,7 +5,7 @@ set(WITH_TESTS ON)
find_package(Googletest MODULE)
add_qtc_test(tst_qml_wizard
- DEPENDS Core Utils StudioWelcome QmlDesigner Googletest
+ DEPENDS Core Utils StudioWelcome ProjectExplorer QmlDesigner Googletest
DEFINES
QT_CREATOR
QMLDESIGNER_TEST
@@ -17,8 +17,13 @@ add_qtc_test(tst_qml_wizard
SOURCES
wizardfactories-test.cpp
stylemodel-test.cpp
+ recentpresets-test.cpp
+ presetmodel-test.cpp
test-utilities.h
+ test-main.cpp
"${StudioWelcomeDir}/wizardfactories.cpp"
"${StudioWelcomeDir}/stylemodel.cpp"
+ "${StudioWelcomeDir}/recentpresets.cpp"
+ "${StudioWelcomeDir}/presetmodel.cpp"
)