summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2022-02-23 18:05:42 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2022-02-24 00:55:29 +0100
commit5d779c622705ed2388288b6f5e172f4e2f239d09 (patch)
tree983f108a3875ff3bade39673da6d593e84dca5d5 /CMakeLists.txt
parent25f4ba54ff856d9cd6f4bdc2a92e7c6d1d3b35a2 (diff)
Add missing Network package
3DCore depends on Qt::Network, but the Network package is not mentioned as required component. In general case it looks like the package is found as the dependency of other targets. So add it explicitly. Pick-to: 6.2 6.3 Change-Id: I26b298e5254c7d5d03ffcb24794180dbec0fd24d Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68c198072..36ed2165b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,13 +13,17 @@ project(Qt3D # special case
# special case begin
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
- Concurrent Widgets Qml Quick Gamepad OpenGL Multimedia)
+ Network Concurrent Widgets Qml Quick Gamepad OpenGL Multimedia)
# special case end
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
return()
endif()
+if(NOT TARGET Qt::Network)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")
+ return()
+endif()
if(WASM OR NOT QT_FEATURE_opengl)
message(NOTICE "Skipping the build as the condition \"QT_FEATURE_opengl AND NOT WASM\" is not met.")
return()