summaryrefslogtreecommitdiffstats
path: root/src/quick3d/quick3drender/CMakeLists.txt
diff options
context:
space:
mode:
authorAhmad Samir <a.samirh78@gmail.com>2023-07-14 03:47:38 +0300
committerAhmad Samir <a.samirh78@gmail.com>2023-07-22 20:47:44 +0300
commit7671478aad2d2a48148852e9ce5a5b598a59f23d (patch)
treeeb43de049f0d0c74d586f276d544988ab3797e90 /src/quick3d/quick3drender/CMakeLists.txt
parent670144a660823238ca286d5b631c9e1ae7dd8f00 (diff)
Build with QT_NO_CONTEXTLESS_CONNECT
This disables the 3-arg QObject::connect() overload: QObject::connect(sender, signal, functor) For details see: https://lists.qt-project.org/pipermail/development/2023-July/044141.html Change-Id: If62d07f687d9ea86995ea813add49216ccaf15cc Reviewed-by: Paul Lemire <paul.lemire@kdab.com>
Diffstat (limited to 'src/quick3d/quick3drender/CMakeLists.txt')
-rw-r--r--src/quick3d/quick3drender/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/quick3d/quick3drender/CMakeLists.txt b/src/quick3d/quick3drender/CMakeLists.txt
index 3e0990e32..6e232019f 100644
--- a/src/quick3d/quick3drender/CMakeLists.txt
+++ b/src/quick3d/quick3drender/CMakeLists.txt
@@ -32,6 +32,8 @@ qt_internal_add_module(3DQuickRender
items/quick3dviewport.cpp items/quick3dviewport_p.h
qt3dquickrender_global.cpp qt3dquickrender_global.h qt3dquickrender_global_p.h
qt3dquickrendernodefactory.cpp qt3dquickrendernodefactory_p.h
+ DEFINES
+ QT_NO_CONTEXTLESS_CONNECT
INCLUDE_DIRECTORIES
items
LIBRARIES