summaryrefslogtreecommitdiffstats
path: root/src/quick3d/quick3drender/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2020-10-07 10:20:57 +0100
committerMike Krus <mike.krus@kdab.com>2020-10-07 16:00:04 +0100
commitbcad723d9c657ab16acd7ae0d31d3b2de512afd4 (patch)
tree5ed4b7a3a48fb131576dc9f70c61f95a54045f87 /src/quick3d/quick3drender/CMakeLists.txt
parent676685f3e1bfe0b93e4d64a0a308f0d24aa41858 (diff)
Use internal CMake API
Task-number: QTBUG-86815 Change-Id: I7a8755571c8977be1f16b2287e5a8055e9016ee5 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/quick3d/quick3drender/CMakeLists.txt')
-rw-r--r--src/quick3d/quick3drender/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/quick3d/quick3drender/CMakeLists.txt b/src/quick3d/quick3drender/CMakeLists.txt
index f38f282cc..5c8685fad 100644
--- a/src/quick3d/quick3drender/CMakeLists.txt
+++ b/src/quick3d/quick3drender/CMakeLists.txt
@@ -4,7 +4,7 @@
## Qt::3DQuickRender Module:
#####################################################################
-qt_add_module(3DQuickRender
+qt_internal_add_module(3DQuickRender
SOURCES
items/quick3deffect.cpp items/quick3deffect_p.h
items/quick3dlayerfilter.cpp items/quick3dlayerfilter_p.h
@@ -55,7 +55,7 @@ qt_add_module(3DQuickRender
## Scopes:
#####################################################################
-qt_extend_target(3DQuickRender CONDITION gcov
+qt_internal_extend_target(3DQuickRender CONDITION gcov
COMPILE_OPTIONS
-fprofile-arcs
-ftest-coverage