aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2022-02-09 18:09:34 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2022-02-14 12:38:10 +0100
commit0f0987c16011b3485ed99660e8c83e3d75d01fd0 (patch)
treefd52af2398114b86dc8ffafe35e4aec26c5de30f /src/quick/CMakeLists.txt
parent4f50697e6cf5c00febda5f54e88ab5de2610c57b (diff)
QtQuick: Add proper QInputMethod singleton
Allow for accessing QInputMethod via a singleton instead of Qt.inputMethod [ChangeLog][QtQuick][New Feature] Qt.inputMethod can now also be accessed via the InputMethod singleton. This allows you to use QInputMethod in a way supported by tooling and the compiler. Fixes: QTBUG-95540 Change-Id: I3366757a1253b202f1fe5320e54c96b70e3b273b Reviewed-by: Andrei Golubev <andrei.golubev@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index 0f8733eb0f..a757ec9afa 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -509,6 +509,10 @@ qt_internal_extend_target(Quick CONDITION QT_FEATURE_wheelevent
handlers/qquickwheelhandler_p_p.h
)
+qt_internal_extend_target(Quick CONDITION QT_FEATURE_im
+ SOURCES
+ util/qquickinputmethod.cpp util/qquickinputmethod_p.h
+)
qt_internal_create_tracepoints(Quick qtquick.tracepoints)
qt_internal_add_docs(Quick