aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorJiDe Zhang <zhangjide@uniontech.com>2022-05-14 11:39:06 +0800
committerJiDe Zhang <zhangjide@uniontech.com>2022-05-31 11:51:43 +0800
commit1df2cf6bad7207f16ddca17344cc1324e50f287e (patch)
tree7efa0366bf9a78adb701c439face3072d57d0d46 /src/quick/CMakeLists.txt
parent711badae7c51409223b0fbb3a15bc0d35a3a8f5e (diff)
Allow specifies the native texture format on QQuickRenderTarget
Add some overloaded function. If you need to use VkImage correctly, Must know the format it corresponds to the VkImage. In the QQuickRenderTarget, It's use the QRhi::newTexture get a QRhiTexture object, and use the QRhiTexture::createFrom to create texture use VkImage and VkImageLayout, on default, it's presume the texture format is QRhiTexture::RGBA8, but the VkImage is source from user, its format is indeterminate, so we should allow to specifies the format of VkImage from user. [ChangeLog][QtQuick] Added an overload for QQuickRenderTarget::fromOpenGLTexture to allow specifying the format of the OpenGL texture. [ChangeLog][QtQuick] Added an overload for QQuickRenderTarget::fromD3D11Texture to allow specifying the format of the D3D11 texture. [ChangeLog][QtQuick] Added an overload for QQuickRenderTarget::fromMetalTexture to allow specifying the format of the Metal texture. [ChangeLog][QtQuick] Added an overload for QQuickRenderTarget::fromVulkanImage to allow specifying the format of the Vulkan texture. Fixes: QTBUG-103216 Change-Id: I3b90be9bbd37439f906351782cf08c060d98cded Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index 20f7ec5beb..7c889cf361 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -397,6 +397,7 @@ qt_internal_extend_target(Quick CONDITION QT_FEATURE_opengl OR QT_FEATURE_opengl
qt_internal_extend_target(Quick CONDITION IOS OR MACOS
SOURCES
scenegraph/coreapi/qsgtexture_mac.mm
+ scenegraph/qsgrhisupport_mac.mm
)
qt_internal_extend_target(Quick CONDITION QT_FEATURE_thread