aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorEskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>2023-08-24 09:57:39 +0200
committerEskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>2023-09-01 11:20:33 +0200
commit8e7572ac63b4eb7ced5148fdca11702108fa511d (patch)
tree748bdad14566f96cfe5b8a4a8178d7ba7ac3a332 /src/quick/CMakeLists.txt
parentac5c7d52737489b2b63071e1003ef2d72e8eb8ae (diff)
Make text node scenegraph API public
A lot of functionality is hidden underneath this, so exposing this API will make it possible to build custom text-based components for Qt Quick. [ChangeLog][Text] Added QSGTextNode and QQuickWindow::createTextNode() for creating scene graph nodes containing text. This can be useful when building custom Qt Quick items with text. Fixes: QTBUG-72773 Change-Id: I4810589cc28eb1cdfe91c9d8b66f4c6fe52a0c6a Reviewed-by: Andy Nichols <andy.nichols@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index ca0947cdb9..aea9223b7c 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -90,7 +90,7 @@ qt_internal_add_qml_module(Quick
items/qquicktextedit_p_p.h
items/qquicktextinput.cpp items/qquicktextinput_p.h
items/qquicktextinput_p_p.h
- items/qquicktextnode.cpp items/qquicktextnode_p.h
+ items/qsginternaltextnode.cpp items/qsginternaltextnode_p.h
items/qquicktextnodeengine.cpp items/qquicktextnodeengine_p.h
items/qquicktextutil.cpp items/qquicktextutil_p.h
items/qquicktranslate.cpp items/qquicktranslate_p.h
@@ -166,6 +166,7 @@ qt_internal_add_qml_module(Quick
scenegraph/util/qsgrhiatlastexture.cpp scenegraph/util/qsgrhiatlastexture_p.h
scenegraph/util/qsgsimplerectnode.cpp scenegraph/util/qsgsimplerectnode.h
scenegraph/util/qsgsimpletexturenode.cpp scenegraph/util/qsgsimpletexturenode.h
+ scenegraph/util/qsgtextnode.cpp scenegraph/util/qsgtexturematerial.h scenegraph/util/qsgtextnode.h
scenegraph/util/qsgtexturematerial.cpp scenegraph/util/qsgtexturematerial.h scenegraph/util/qsgtexturematerial_p.h
scenegraph/util/qsgtextureprovider.cpp scenegraph/util/qsgtextureprovider.h
scenegraph/util/qsgtexturereader.cpp scenegraph/util/qsgtexturereader_p.h