aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorRichard Moe Gustavsen <richard.gustavsen@qt.io>2021-05-14 12:13:36 +0200
committerRichard Moe Gustavsen <richard.gustavsen@qt.io>2021-06-03 10:30:53 +0200
commitd1313feb83b52e58d1a0a4f51fd58668ff99c575 (patch)
treeac0f0b45ecb314939612dac9de41bf1c211d63ef /src/quick/CMakeLists.txt
parenta51317b45cb0bc2f335fcb28dc8eb58825e65faa (diff)
Selection support: add private interface QQuickSelectable
Add a private interface that can be used for controlling selections. This interface will initially be implemented by TableView, but also ListView, GridView, and potentially any component can implement this interface. Next, a visual selection tool called SelectionRectangle will be added to Controls. This tool has e.g styled selection handles, and does therefore not belong in Quick. This tool will not communicate directly with TableView, but through the added interface. That way, the tool can be reused for any component / control in Quick or Controls that needs a selection tool, and implements the interface. Change-Id: I1cf9d4ba9c063676ef6458e0cfd9d077bed0d4d0 Reviewed-by: Mitch Curtis <mitch.curtis@qt.io> Reviewed-by: Shawn Rutledge <shawn.rutledge@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index 03eb3ee768..56c928b01e 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -456,6 +456,7 @@ qt_internal_extend_target(Quick CONDITION QT_FEATURE_quick_tableview
SOURCES
items/qquicktableview.cpp items/qquicktableview_p.h
items/qquicktableview_p_p.h
+ items/qquickselectable_p.h
)
qt_internal_extend_target(Quick CONDITION QT_FEATURE_quick_pathview