aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/animation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/animation/CMakeLists.txt')
-rw-r--r--examples/quick/animation/CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/examples/quick/animation/CMakeLists.txt b/examples/quick/animation/CMakeLists.txt
index 877a30be60..52fa6c0f44 100644
--- a/examples/quick/animation/CMakeLists.txt
+++ b/examples/quick/animation/CMakeLists.txt
@@ -4,8 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(animation LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,18 +12,17 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/animation")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
+qt_standard_project_setup()
+
add_subdirectory("../shared" "shared")
qt_add_executable(animationexample
+ WIN32
+ MACOSX_BUNDLE
main.cpp
)
-set_target_properties(animationexample PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(animationexample PUBLIC
+target_link_libraries(animationexample PRIVATE
Qt::Core
Qt::Gui
Qt::Qml