aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/imageelements/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quick/imageelements/CMakeLists.txt')
-rw-r--r--examples/quick/imageelements/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/quick/imageelements/CMakeLists.txt b/examples/quick/imageelements/CMakeLists.txt
index 52e7eb53c1..9011880f65 100644
--- a/examples/quick/imageelements/CMakeLists.txt
+++ b/examples/quick/imageelements/CMakeLists.txt
@@ -4,8 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(imageelements LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -14,6 +12,8 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/imageelements")
find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
+qt_standard_project_setup()
+
add_subdirectory("../shared" "shared")
qt_add_executable(imageelementsexample
@@ -22,7 +22,7 @@ qt_add_executable(imageelementsexample
main.cpp
)
-target_link_libraries(imageelementsexample PUBLIC
+target_link_libraries(imageelementsexample PRIVATE
Qt::Core
Qt::Gui
Qt::Qml